Kia Optima Forums banner
1 - 11 of 11 Posts

·
Registered
2015 Kia Optima SXL Turbo
Joined
·
4 Posts
Discussion Starter · #1 ·
Just bought a 2015 Kia Optima SXL Turbo at a really good deal. But I'm having a weird problem with the bluetooth. It works just fine, but around 15 minutes into listening it will stop playing audio. I noticed that my PHONE shows the bluetooth disconnected, but the car is confused and thinks it's still connected.

I'm wondering if this is a common problem or if anyone might know of some good ways to fix it.
 

·
Registered
2013 Kia Optima
Joined
·
258 Posts
Just bought a 2015 Kia Optima SXL Turbo at a really good deal. But I'm having a weird problem with the bluetooth. It works just fine, but around 15 minutes into listening it will stop playing audio. I noticed that my PHONE shows the bluetooth disconnected, but the car is confused and thinks it's still connected.

I'm wondering if this is a common problem or if anyone might know of some good ways to fix it.
First make sure it doesn't do it with another bluetooth system before thinking it's the vehicle and not your phone unless you already have?
 

·
Registered
2013 Kia Optima
Joined
·
258 Posts
I already have, it works well in my 2017 Honda CRV as well as with my AirPods, Sony Headphones, etc.
The fuse box under the dash has a group of fuses in a yellow holder for memory and such. You can try to pull them out for a little to reset everything and try again and see what happens. If it doesn't fix it may need to find a head unit at a junkyard, put up with it or use usb or something.
 

·
Registered
2015 Kia Optima SXL Turbo
Joined
·
4 Posts
Discussion Starter · #5 ·
The fuse box under the dash has a group of fuses in a yellow holder for memory and such. You can try to pull them out for a little to reset everything and try again and see what happens. If it doesn't fix it may need to find a head unit at a junkyard, put up with it or use usb or something.
Would you recommend removing these fuses / re-inserting them while the vehicle is running? Or does that matter.
 

·
Registered
2012 Black SX Prem. & Tech.
Joined
·
2,320 Posts
Also perform a reset procedure on the car's head unit. I don't know the procedure for the 2015, but on my 2012, you just hold down one of the buttons for like 10-15 seconds and then the system will power off and power back on.

If that doesn't help, then you could re-flash the system, by purchasing a map update. You can install it twice in a row to be sure (I had to do that once, when my system developed a black screen issue).
 

·
Registered
2015 Kia Optima SXL Turbo
Joined
·
4 Posts
Discussion Starter · #7 ·
I reseeded the fuse and it seemed to fix the problem for an hour or two. But then it came back :(. I’m worried it might be the head unit itself now, but I have the higher end one with GPS and whatnot in it. I feel it might be more expensive to replace. I’m also assuming that the “head unit” is the piece of equipment that houses the screen and controls itself.
 

·
Registered
Joined
·
43 Posts
I'd also try purchasing a map/software upgrade as well. I think on newer-ish cars it's a free download.

My 2013 Optima w/ Nav wasn't displaying song information when playing via Bluetooth when I bought it. I picked up a ~$20 upgrade for my map data (which also included a general software update) and now I have the song information as expected. I wasn't experiencing any other issues though so I can't say it'll solve your problem.

Have you tried with a different phone to see if the problem persists?
 

·
Registered
Joined
·
3 Posts
I'd also try purchasing a map/software upgrade as well. I think on newer-ish cars it's a free download.

My 2013 Optima w/ Nav wasn't displaying song information when playing via Bluetooth when I bought it. I picked up a ~$20 upgrade for my map data (which also included a general software update) and now I have the song information as expected. I wasn't experiencing any other issues though so I can't say it'll solve your problem.

Have you tried with a different phone to see if the problem persists?
Where did you get this update. my 2013 sxl with the infinity nav just keeps saying bluetooth initializing. and it wont connect to anything via usb. nor does my navigation work. I dont know what the issue is.
 

·
Registered
2012 Black SX Prem. & Tech.
Joined
·
2,320 Posts
The map update is available at Mapnsoft, refer to other discussion for detailed instructions on how to find the code in your NAV system, then go to the Mapnsoft website to provide that code to them so they can generate the custom installation and mail it to you via USB once you buy the map update.

But really it sounds like you just need to reboot your NAV system. That reboot procedure is found in another discussion on this site, sorry I cannot remember the exact procedure, but I think it involves holding down some buttons or like the map button for like 15 seconds until the NAV system reboots. So this reboot procedure is different than just holding down the power button for 3 seconds when you turn of the NAV system. Instead, it involves more time and actually reboots.
 
1 - 11 of 11 Posts
Top