Kia Optima Forums banner
1 - 6 of 6 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
I have a 2012 Kia Optima. I have had the worst trouble with this car. I bought it used about 6 yrs ago and 4 yr a ago air went out, last year Kia replaced the engine and now I’m having to take my car into a transmission place because I got the code of p0713 and p0711. The dealership from where I was kept telling me they wouldn’t look at my car unless the check engine light was off . Literally every time I would drive it to the dealership light would go off so they said it wasn’t a transmission issue and couldn’t get a code. I took it to oreilys and got codes so now heading to the transmission place because the dealership has been so horrible to me. Hoping it’s just the transmission temperature sensor like the codes say
 

·
Registered
Joined
·
2 Posts
Discussion Starter · #3 ·
That was my understanding but 2 Kia dealerships said they needed the light on. One dealership told me that last week that’s why I pulled the codes and called a transmission guy. Hoping it’s the temperature sensor like the code says.
 

·
Registered
Joined
·
1,342 Posts
You know, my sensor acted up this winter after leaving the car out on a very cold night. I have not seen the code for several months now. I suspect it will show up again this winter...
 

·
Registered
2012 Optima SX-T
Joined
·
17 Posts
My sensor went out at 55,931 right before my fuel pump at 56,830 miles. This was back in July 2015 and was covered under warranty.
 
1 - 6 of 6 Posts
Top