Kia Optima Forums banner

41 - 60 of 62 Posts

·
Registered
Joined
·
9 Posts
Same issue as you all. Mine had wrong date and time. I went to change the settings for the clock and I was able to adjust the date and time but when I went back it was all greyed out and it didn't give me the option to do any of the date and time settings. Interesting how we all have the same issue in what appears to be the same day. I took out the chip that's inside on the radio control area to reset it and that didn't do anything. We also notice that it won't let us update because of an error code regarding memory. My car is a 2015 Kia Optima SX
remove the fuse for multimedia and reinstall. that worked for me
 

·
Registered
Joined
·
9 Posts
I tried all of that too and it doesn’t work. Do y’all think it will fix on its own or will I have to go to dealership?🙁
I tried all those steps and the only thing worked was removing the fuse for multimedia and reinstalling it. Removing SD card or resetting the system didnt work for me.
 

·
Registered
Joined
·
5 Posts
Removing the SD card just now worked for me! The trick is you have to try it more than once. The first time it went back to dashes, so I tried it again and the second time after it rebooted the date and time came up. I would recommend everyone try removing the SD card a couple times before resorting to the other methods.
 

·
Registered
Joined
·
1 Posts
I started having the same problem on my '17 Optima SXL. Glad to know I'm not the only one, but none of the suggested fixes have worked for me. Ugggh.
 

·
Registered
Joined
·
497 Posts
Apparently the issue hasn't (yet?) manifested itself on my 2018 SXL as both the date and time are (still) correct.
 

·
Registered
Joined
·
1 Posts
I have a 2016 Kia Optima-get in it yesterday and the date is all crazy. (Feb 6 and showing like 4am when it was 8pm) I get in it today and now there is no date and no time displaying at all. When I go to the clock settings, everything is grayed out so there is no option to display. I’ve tried turning the power off and then turning the car off-nothing is working so far. Help!
SAME THING HAPPENED TO ME. GO TO SETTINGS AND UPDATE OPTION FOR NAV SYSTEM (CHOOSE CONTINUE WHEN IT SAYS YOU ALREADY HAVE THE LATEST) AND IT WILL REINSTALL KEEPING ALL YOUR POI'S AND PREVIOUS SETTINGS. WORKS FINE AFTER THE RESET.
 

·
Registered
Joined
·
1 Posts
I have a 2017 Optima SX Turbo and I am having the same problem with the clock and date as well. We just did the reset with the SD card and it worked!! You have to wait a few seconds for it to reset after you put the card in and the screen comes up.
 

·
Registered
Joined
·
4 Posts
I have a 2016 Kia Optima-get in it yesterday and the date is all crazy. (Feb 6 and showing like 4am when it was 8pm) I get in it today and now there is no date and no time displaying at all. When I go to the clock settings, everything is grayed out so there is no option to display. I’ve tried turning the power off and then turning the car off-nothing is working so far. Help!
Mine did the same the other day, you have to take out the SIM card for about a minute with the car running and outside and it should reboot and fix. Had to take mine out twice before it
I have a 2016 Kia Optima-get in it yesterday and the date is all crazy. (Feb 6 and showing like 4am when it was 8pm) I get in it today and now there is no date and no time displaying at all. When I go to the clock settings, everything is grayed out so there is no option to display. I’ve tried turning the power off and then turning the car off-nothing is working so far. Help!
Happened to me also, remove the SIM card for about a minute with the car running and replace.
My clock and date returned on the second try.
Don’t do it in your garage.
 

·
Registered
Joined
·
1 Posts
Mine gives a memory error and wont let me update. "Please check the update memory and try again "
 

·
Registered
Joined
·
276 Posts
Mine gives a memory error and wont let me update. "Please check the update memory and try again "
You need to remove the Multimedia fuse in fuse box under dash while car is running, using the fuse removal tool in fuse box under hood. Turn car off, reinstall the fuse. Your clock will then reappear with correct time.
 

·
Registered
Joined
·
1 Posts
I've had the same issue as everyone else here, except my clock just went away, as well as the date. They were gone for about 3 days and then I get into my car yesterday morning and they are back. Date and time are correct too! I have no idea what happened but I'm glad it's all back to normal. I drive a 2016 Kia Optima.
 

·
Registered
Joined
·
17 Posts
I located the fuse and removed it while the car was off. You can use the tool that is provided under the hood fuse box. I then started the car and let it run for a min. You will notice that the unit is off. Ok turn off car and reinstall fuse. Fire it up again and you should be back in business.
Cheers! View attachment 247209 View attachment 247210

Sent from my SM-N960W using Tapatalk
Big thanks for this suggestion as it was the only thing that worked for me! A few things to note for those who are also having trouble with this:
  • As many others have suggested, removing the SD card, pushing the reset button, and re-inserting the SD card did not bring the clock back for me. Although it seemed to have fixed the problem for a lot of people, if it didn't fix the issue for you, keep reading below.
  • The fuse removal tool is located under the hood in the engine bay and the fuse box where you need to remove the fuse is located inside the car
  • After removing the fuse, I started the engine and turned it back off. Once I re-inserted the fuse, I started the engine again and no clock info was displaying, but as soon as I pressed the settings button, it refreshed right away
For reference, I have a 2016 Optima EX. Hope this helps somebody!
 

·
Registered
Joined
·
2 Posts
When pulling the SD card, it only worked for me to pull out of garage when updating. Works fine now.. Thanks everyone!!
 

·
Registered
Joined
·
4 Posts
I have a 2016 Kia Optima-get in it yesterday and the date is all crazy. (Feb 6 and showing like 4am when it was 8pm) I get in it today and now there is no date and no time displaying at all. When I go to the clock settings, everything is grayed out so there is no option to display. I’ve tried turning the power off and then turning the car off-nothing is working so far. Help!
Just found the fix. With car running, remove nav SD card. Use tip of pen and push reset button just above recessed SD card slot. Put SD card back in and allow system to reboot. Takes a couple minutes. Viola! Everything works!
 

·
Registered
Joined
·
1 Posts
I have a 2016 Kia Optima-get in it yesterday and the date is all crazy. (Feb 6 and showing like 4am when it was 8pm) I get in it today and now there is no date and no time displaying at all. When I go to the clock settings, everything is grayed out so there is no option to display. I’ve tried turning the power off and then turning the car off-nothing is working so far. Help!
I had to do a system update under the setup tab....just use the existing one in the stereo....takes about 25 minutes to complete.
 
41 - 60 of 62 Posts
About this Discussion
61 Replies
37 Participants
CessnaFlyer
Kia Optima Forums
Optima Forums is the community to discuss the Kia Optima as well as custom Kias and all the accessories to personalize your Kia!
Full Forum Listing
Top