Kia Optima Forums banner

1 - 7 of 7 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter · #1 ·
Just put some dirt cheap Chinese made D1S low beams in bc one of my lows went out earlier this week. Now when I turn my high beams on, the fog lights cut off as usual but the low beams stay lit. Did I screw something up and should I be concerned?
 

·
Registered
2013 Ebony SXL Turbo: Original Everything @ about 189K with Drag wheels.
Joined
·
322 Posts
Seems like a nifty feature assuming no fuses are blowing which it does not sound like it.
Bonus points if you can get the fogs to stay on too!
 

·
Registered
Joined
·
4 Posts
Discussion Starter · #5 ·
I appreciate your hustle. So far so good on the cheapos, but when they fail I will be ordering some of those XBs.
 

·
Your K5 Optima Vendor
Tesla Model X P100D
Joined
·
28,639 Posts
I appreciate your hustle. So far so good on the cheapos, but when they fail I will be ordering some of those XBs.
My pleasure, in the past we have seen them start flickering or only 1 side comes on when turning the lights on. (Hopefully that won't happen to you though)
 

·
Registered
Joined
·
359 Posts
Just put some dirt cheap Chinese made D1S low beams in bc one of my lows went out earlier this week. Now when I turn my high beams on, the fog lights cut off as usual but the low beams stay lit. Did I screw something up and should I be concerned?
have u tried switching on the lows first and then the fogs? also the fogs is it the halogen bulb or HID? i have encountered fogs wont turn on with HID, unless hooked into a relay to trick the circuit that its not drawing much current.
 
1 - 7 of 7 Posts
Top