Kia Optima Forums banner
1 - 13 of 13 Posts

·
Registered
Joined
·
7 Posts
Discussion Starter · #1 ·
After the latest update, sometimes, after driving around town slowly, the car does not want to go at after sitting at a stop light. It registers the pedal is down because the Eco gauge goes to the red. If I take off conservatively, you might as well expect me to run a red light because it takes so long to get going. If I slowly push it to the floor, it feels like someone is pushing my car by hand and when it hits 3 or 4 mph, the engine finally revs and the car accelerates.
 

·
Registered
2018 Kia Optima EX
Joined
·
2 Posts
After the latest update, sometimes, after driving around town slowly, the car does not want to go at after sitting at a stop light. It registers the pedal is down because the Eco gauge goes to the red. If I take off conservatively, you might as well expect me to run a red light because it takes so long to get going. If I slowly push it to the floor, it feels like someone is pushing my car by hand and when it hits 3 or 4 mph, the engine finally revs and the car accelerates.
 

·
Registered
2018 Kia Optima EX
Joined
·
2 Posts
After the latest update, sometimes, after driving around town slowly, the car does not want to go at after sitting at a stop light. It registers the pedal is down because the Eco gauge goes to the red. If I take off conservatively, you might as well expect me to run a red light because it takes so long to get going. If I slowly push it to the floor, it feels like someone is pushing my car by hand and when it hits 3 or 4 mph, the engine finally revs and the car accelerates.
Mine does this also!!
 

·
Registered
2013 Kia Optima
Joined
·
178 Posts
After the latest update, sometimes, after driving around town slowly, the car does not want to go at after sitting at a stop light. It registers the pedal is down because the Eco gauge goes to the red. If I take off conservatively, you might as well expect me to run a red light because it takes so long to get going. If I slowly push it to the floor, it feels like someone is pushing my car by hand and when it hits 3 or 4 mph, the engine finally revs and the car accelerates.
What latest update? If it's as bad as you make it sound, there should be a check engine light.
 

·
Registered
Joined
·
2 Posts
What latest update? If it's as bad as you make it sound, there should be a check engine light.
My 2015 sx turbo does throw a code. However the first time I cleared it the second time it cleared itself. It did say engine control system issue detected & the first was a turbo sensor position was high. It goes to the shop today so we’ll see what they say.
 

·
Registered
2013 Kia Optima
Joined
·
178 Posts
My 2015 sx turbo does throw a code. However the first time I cleared it the second time it cleared itself. It did say engine control system issue detected & the first was a turbo sensor position was high. It goes to the shop today so we’ll see what they say.
You probably need a wastegate adjustment. don't let them sell you anything. not sure about the other guys issue tho.
 

·
Registered
Joined
·
7 Posts
Discussion Starter · #9 ·
What latest update? If it's as bad as you make it sound, there should be a check engine light.
No check engine light. Since the update from the knock sensor, it hasn't ran the same. It even has problems down shifting. When I left the shop, I slowed down for a stop light and thought I was rear ended because thr car jerked so hard when it shifted down.
 

·
Registered
2013 Kia Optima
Joined
·
178 Posts
No check engine light. Since the update from the knock sensor, it hasn't ran the same. It even has problems down shifting. When I left the shop, I slowed down for a stop light and thought I was rear ended because thr car jerked so hard when it shifted down.
Leave the battery cables off overnight. When you hook them back up in the morning the vehicle will go through a relearn process and maybe it will fix it. Could take 50-75 miles to complete the relearn and to throw a code if something is wrong. If nothing changes I would take it back and say it hasn't been right since.
 

·
Registered
Joined
·
2 Posts
After the latest update, sometimes, after driving around town slowly, the car does not want to go at after sitting at a stop light. It registers the pedal is down because the Eco gauge goes to the red. If I take off conservatively, you might as well expect me to run a red light because it takes so long to get going. If I slowly push it to the floor, it feels like someone is pushing my car by hand and when it hits 3 or 4 mph, the engine finally revs and the car accelerates.
Hi,i got mine done yesterday and have same problem and loss of about 8-10 mpg fwy and city!!gonna contact dealership in the morning
 

·
Registered
Joined
·
2 Posts
Hi,i got mine done yesterday and have same problem and loss of about 8-10 mpg fwy and city!!gonna contact dealership in the morning
hi,not only worse performance and lower mpg but dealership wants $175 to diagnose whatever there "update" created?i think it blew the oil pressure connector sensor which i had replaced in june 2020,if anyone else is still experiencing poor performance since update please let me know what steps u have taken
 

·
Registered
Joined
·
7 Posts
Discussion Starter · #13 ·
hi,not only worse performance and lower mpg but dealership wants $175 to diagnose whatever there "update" created?i think it blew the oil pressure connector sensor which i had replaced in june 2020,if anyone else is still experiencing poor performance since update please let me know what steps u have taken
I was wondering about the performance and fuel efficiency...it doesn't seem to accelerate near as good and I can't get 30 mpg on the highway anymore. It also seems to struggle down shifting when slowing down or stopping. I ran over a deer and torn the front bumper apart and thought that's why my mpg's dropped. It's currently in the body shop and then I'm taking it back to kia for them to fix their update.
250333
 
1 - 13 of 13 Posts
Top