Kia Optima Forums banner
1 - 8 of 8 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter · #1 ·
so I got side swiped the other day and it damaged my mirror on our 2016 kia optima ex. I bought a replacement and switched it out. Now here comes the issues. I went to lock it after replacing the mirror and it let out a long honk and stayed locked. I had to bust out the key to get back into the car. Now anytime I go to lock it it will not lock. If the lights are on when i shut the car off the drl lights stay on even if i shut them off after the car is off. I have to turn the car back on and switch the drl off and then shut the car off. Before you could hit the memory seat with the car off and the seat would move, now the car has to be on in order to use it. As soon as you turn the car off everything is off no lights or anything. I have checked fuses and also unpluged the battery and did a software update and nothing. Any ideasas to what might be going on?
 

·
Registered
2012 Black SX Prem. & Tech.
Joined
·
2,594 Posts
Do you have the old broken mirror still?

I'd suggest disconnecting the battery, and swapping back to the broken mirror, then connecting the battery, and see if the problems go away.

The question is did the new mirror mess up something in the car that has to be fixed (like a burnt fuse), or did the new mirror just confuse the car while its connected and nothing is messed up with the car.
 

·
Registered
Joined
·
4 Posts
Discussion Starter · #6 ·
Do you have the old broken mirror still?

I'd suggest disconnecting the battery, and swapping back to the broken mirror, then connecting the battery, and see if the problems go away.

The question is did the new mirror mess up something in the car that has to be fixed (like a burnt fuse), or did the new mirror just confuse the car while its connected and nothing is messed up with the car.
I took the old one off and took it apart thinking I could fix it, ended up taking the cover off since the new one is black to be painted. Figured I'd just switch the covers and don't need to paint then. I put the old one back on and all of this happened. I had taken it off and put the new one on and still no change, even after unplugging the battery for an hour.
 
1 - 8 of 8 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top