Kia Optima Forums banner
1 - 6 of 6 Posts

·
Registered
2015 Kia Optima
Joined
·
3 Posts
Discussion Starter · #1 ·
Last Monday I bought a 2015 Optima EX. It started out as an intermittent issue where the car wouldn't shut off fully after you put it in park and turn the engine off. The dashboard would indicated that the vehicle was in park, but in the screen in the center of the speedometer it says "Shift into P" and it would keep the car in accessory mode. The issue progressed to the point where it wouldn't resolve on its own. I took the car to the dealer and they said there was a tab in the shifter assembly that wasn't aligned properly. Got the car back and it was fine for a couple hours until I got home and the issue returned. The car has been back at the dealership for a few days now. Any ideas on what could cause this issue? I would like to actually get to drive the car I just bought..
 

·
Registered
2016 Kia Optima SXL
Joined
·
672 Posts
This is a "First" for my Forum reading BUT File Away for future Uh-Oh's ... IF your Gear Position Dash Display (P, R, N, D), ever goes Blank and it's tough to shift - it has always been ... Error Code 0705 - Inhibitor Switch -..... 1st Trip to Svc didn't Show Error Code but the 2nd occurrence did. It cleared-up After Engine Off but returned later ........ New Switch = Good.
 

·
Registered
Joined
·
2 Posts
Any fix on this? because I’m dealing with it at the moment
Last Monday I bought a 2015 Optima EX. It started out as an intermittent issue where the car wouldn't shut off fully after you put it in park and turn the engine off. The dashboard would indicated that the vehicle was in park, but in the screen in the center of the speedometer it says "Shift into P" and it would keep the car in accessory mode. The issue progressed to the point where it wouldn't resolve on its own. I took the car to the dealer and they said there was a tab in the shifter assembly that wasn't aligned properly. Got the car back and it was fine for a couple hours until I got home and the issue returned. The car has been back at the dealership for a few days now. Any ideas on what could cause this issue? I would like to actually get to drive the car I just bought..
 

·
Registered
2014 kia optima LX
Joined
·
3 Posts
Last Monday I bought a 2015 Optima EX. It started out as an intermittent issue where the car wouldn't shut off fully after you put it in park and turn the engine off. The dashboard would indicated that the vehicle was in park, but in the screen in the center of the speedometer it says "Shift into P" and it would keep the car in accessory mode. The issue progressed to the point where it wouldn't resolve on its own. I took the car to the dealer and they said there was a tab in the shifter assembly that wasn't aligned properly. Got the car back and it was fine for a couple hours until I got home and the issue returned. The car has been back at the dealership for a few days now. Any ideas on what could cause this issue? I would like to actually get to drive the car I just bought..

did anyone find a solution?
 

·
Registered
Joined
·
2 Posts
did anyone find a solution?
I think I did. I actually had to take off the plastic on my gearshift console. Inside there’s a latch connected to where the gear shift is. That latch actually clicks when I squeeze it. (This is the best way to explain sorry)…when I hold it down and turn the car off, it fully turns off. Meaning whatever was attached to it broke or fell off. So I had to use a very small clamp to keep it clamped down. You wont find a YouTube video on it and no one else will help. So I hope this helps!
 
1 - 6 of 6 Posts
Top