Kia Optima Forums banner

1 - 2 of 2 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1 (Edited)
Hey guys, so here's the situation.

I own a 2019 Kia Optima EX with navigation head unit, and it is stuck on it's boot screen, the UVO display.

I have tried everything.
247689

I worked for a dealership as a sales consultant and product specialist, and I recently changed jobs. My service department, when the issue originally occurred, they must've just ordered a radio and skipped the diagnosis and claimed warranty on it. Because three days later, it was back and now they're are basically not willing to do anything. It's about $5,700 to fix fully replace this if warranty doesn't cover it. The issue I have is, I have a masssssssssssive sound system added into this vehicle. I have two JL, an addition JL TWK and FIX sound processors, etcs.... and guess what, my car is being drained overnight now out of no where since this issue arouse.

I know it isn't my sound system, it runs off of a circuit breaker that I have flipped off, and there is absolutely no juice going back to the setup. But Kia obviously has a way to void my warranty now thanks to this, and I can't exactly remove this.... my entire car is sound deadened. from cabin to trunk, and I'm sure they'll notice and I'll have spent all the time removing everything just for them to ask "So where's the aftermarket system you obviously pulled?"

The radio works, it will play FM/AM, but no bluetooth connectivity or signal is being output. I have used multiple sources of linux software, and there is no broadcast of any form being emitted from my vehicle. There is nothing when I tap the LTE antennae, there is no TCP/UDP, GSM, IPv6, IPv4, WiFi, there is nothing. My UVO Link app doesn't think I've started my vehicle since about 1100 miles ago also, and says "network error or no reception" when attempting to issue a command.

I have even tried to remotely connect via SSH, HTTP commands that UVO sends, I have tried communicating via the USB port, then I said screw it, pulled the radio and tried to find a UART port to tap into for the firmware and wasn't successful at identifying one and put it back miserably. Here are some photos to laugh at.

I have read thousands of lines of code, trying to understand where there could be a way to get into the firmware and wake this freaking thing up out of the boot loop it's in, and I've lost myself into the rabbit hole. My girlfriend's left me, and it's half the reason I don't have a job because I've gone insane.
I've torn apart the HKMC_Navi.apk file inside the sd card, I've managed to get a dumpstate file and I've literally read. (20k lines).

The last thing I havent done, I have these files...

cache.sparse.img
qb_data.sparse_20190401.202021.img
snapshot.raw.img
snapshot.sparse_20190401.202021.img
userdata.sparse.img

I'm unsure what to do with these, but I'm assuming these files contain the architecture of the radio.

Somebody #@$&ing help me please.
I'm on my own with this.


247690
247691
247692
247693
 
1 - 2 of 2 Posts
Top