Kia Optima Forums banner
1 - 8 of 8 Posts

·
Registered
2011 Kia Optima
Joined
·
11 Posts
Discussion Starter · #1 ·
Hello everyone, I need to replace the engine in my 2011 optima hybrid after it was severely damaged after overheating. I am searching online and find very confusing information about engine compatibility between 2011-2012 model years and newer >2013. Do they have the same engine or not?
 

·
Super Moderator
2012 Kia Optima
Joined
·
3,486 Posts
Why don't you call the dealer and get the part numbers from them so you can shop around? Goodluck!
 

·
Registered
2011 Kia Optima
Joined
·
11 Posts
Discussion Starter · #3 ·
Update: bought used engine from 2013 model year. Almost the same as 2011 with slight modification ( 2 hoses running coolant from thermostat to oil filter housing, I guess they improved it after 2012). The car was sitting for 2 month and now after engine being installed I get no crank condition, state of charge says high voltage battery is 0. But I opened the battery service port and measured voltage and it was 240V so it should be able to crank the engine. Trying to troubleshoot the problem. Does anyone have an idea where to look ? Thanks
 

·
Registered
2011 Kia Optima
Joined
·
11 Posts
Discussion Starter · #5 · (Edited)
Replied in the other forum thread, that on hybrid optima/sonata HDG cranks the engine, while 12v battery supplies power for ignition and computer.
Still after trying everything that I was possible in my garage , had it towed today to the dealer for diagnostic. Other interesting detail is that nobody from local hybrid independent mechanics is working on Kia hybrid system.
There is very little infrormation in the public domain on how to repair/diagnose these cars....
 

·
Registered
2011 Kia Optima
Joined
·
11 Posts
Discussion Starter · #6 ·
Update : after couple of days at the dealer my car is now running again and getting about 36mpg in mixed city/highway driving. Their diagnosis found that due to some glitch in the hybrid system the computer did not command the gasoline engine to be started, but at the same time the high voltage battery was discharged below the level when car can drive in EV mode.
So basically they reset the system and forced gasoline engine start, which charged the hybrid battery and car is up and running again.
So takeaways from this exercise:
1. Engine from 2013-2016 fits 2011-2012 models without any problems
2. No crank condition might be due to hybrid system glitch, even with new 12v battery and high voltage battery showing 240v.

Thanks for comments and help.
 

·
Registered
Joined
·
2 Posts
Update : after couple of days at the dealer my car is now running again and getting about 36mpg in mixed city/highway driving. Their diagnosis found that due to some glitch in the hybrid system the computer did not command the gasoline engine to be started, but at the same time the high voltage battery was discharged below the level when car can drive in EV mode.
So basically they reset the system and forced gasoline engine start, which charged the hybrid battery and car is up and running again.
So takeaways from this exercise:
1. Engine from 2013-2016 fits 2011-2012 models without any problems
2. No crank condition might be due to hybrid system glitch, even with new 12v battery and high voltage battery showing 240v.

Thanks for comments and help.
Are u. Shore. About. 2013 -2016. Being the same. I have. A. 2013. I need a new engine so i can. Swap it with a. 2016 one. ? Can u ease tell me Were did u find that information
 

·
Registered
Joined
·
13 Posts
Did you have to pull out the transmission or drop the transmission to get the engine enough clearance to pull it out ? Currently swapping a 2015 hybrid motor on my 2012 kia hybrid
 
1 - 8 of 8 Posts
Top