Kia Optima Forums banner
1 - 2 of 2 Posts

·
Registered
2013 Optima SXL
Joined
·
44 Posts
Discussion Starter · #1 ·
Has anyone had to change out their Purge Control Valve and if so, where was it? I have a 2013 Optima SXL. Runs fine except for after i fill the tank. First time attempting to start it, after getting gas, its a very rough start. Little research makes me believe its possibly the Purge Control Valve. Also says its a pretty easy change out. So figured Id start there before taking it in. Couldnt find anything specific to the Optima, but a few things saying its in the air filter hose area or under the engine cover on the right side (while looking at the engine), but just wanted to make sure before i start tearing things apart.

Thanks in advance for any assistance!
 

·
Registered
Joined
·
6 Posts
Has anyone had to change out their Purge Control Valve and if so, where was it? I have a 2013 Optima SXL. Runs fine except for after i fill the tank. First time attempting to start it, after getting gas, its a very rough start. Little research makes me believe its possibly the Purge Control Valve. Also says its a pretty easy change out. So figured Id start there before taking it in. Couldnt find anything specific to the Optima, but a few things saying its in the air filter hose area or under the engine cover on the right side (while looking at the engine), but just wanted to make sure before i start tearing things apart.

Thanks in advance for any assistance!
Andrew, did you ever figure anything out with the FCV needle? What were your symptoms, did you read the TSB#10089786? I'm just trying to figure out what's wrong with my 2912 Optima SX turbo...decelerates during acceleration, rough idle while braking at a stop, loud exhaust, poor performance overall on my end. Need help asap, can't see dealership for inspection for another month.
 
1 - 2 of 2 Posts
Top