Kia Optima Forums banner
1 - 5 of 5 Posts

·
Registered
Joined
·
28 Posts
Discussion Starter · #1 ·
So I’ve had my brakes redone and they supposedly did my parking brake again but I still am able to back up and drive forward on when the break is on “I know I’m not supposed to but sometimes I forget” is anybody else have this problem
 

·
Registered
2011 Kia Optima
Joined
·
3,604 Posts
2015, but what type parking brake, manual push type or ESP?
If manual, get some leg strength and really mash the pedal down and see if it holds.
 

·
Registered
Joined
·
28 Posts
Discussion Starter · #3 ·
2015, but what type parking brake, manual push type or ESP?
If manual, get some leg strength and really mash the pedal down and see if it holds.
I will try that, if I had them bleed the line would that help too?
 

·
Registered
2012 Black SX Prem. & Tech.
Joined
·
2,294 Posts
Another thing to try: repeated application and release of the manual parking brake pedal.

My car has the manual pedal for the parking brake. At first use, it would not hold the car well, no matter how hard I pressed it to the floor.

Instead, I applied it, and released it, and applied it, and released it. Each time, the parking brake held stronger and stronger. Finally, after about six to eight applications, the parking brake was very strong, completely different and welcome behavior.

So try that, multiple repeated applications and releases of the parking brake, until it firms up. Press it hard too, with each application. It's a one-time thing, once you do it, the manual parking brake should be working fine and normal once again going forward. You don't need to do this repetition each time. Just once should fix or reset things back to normal.
 

·
Registered
2012 Kia Optima SX
Joined
·
22 Posts
1 - 5 of 5 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top