Kia Optima Forums banner
1 - 18 of 18 Posts

·
Registered
Joined
·
20 Posts
Discussion Starter · #1 ·
Has anyone ever experienced this code p0299 low boost and what did you find the problem to be im getting this code on my 2013 optima sxl 2.0T right now can anyone please help
 

·
Registered
2012 Black SX Prem. & Tech.
Joined
·
2,184 Posts
Not sure about that specific code, but it may be related to the wastegate adjustment for the turbo. There are other discussions on that topic.
 

·
Super Moderator
2012 Kia Optima
Joined
·
3,486 Posts
Has anyone ever experienced this code p0299 low boost and what did you find the problem to be im getting this code on my 2013 optima sxl 2.0T right now can anyone please help
its the electronic wastegate. its probably fallen out of spec and you need an adjustment. There is a youtube video if you are a DIYer but your dealership can do it as well for like $60 bucks. Its also best to take readings on the ewg when the engine is bone cold.
 

·
Registered
2018 Kia Optima
Joined
·
1,147 Posts
...but your dealership can do it as well for like $60 bucks.
LOL that's if you have a friendly dealership that doesn't insist on charging you their mandatory $100+ diagnostic fee just so that they can tell you what you already know...
 

·
Premium Member
2012 Kia Optima
Joined
·
51 Posts
Temery - Any luck getting this fixed? I've got the same thing, no check engine light, but P0299 code via Torque. No turbo feel on acceleration but I hear the turbo whine. Other users have reported an intercooler leak. I have a 2012 SX with 127k salty Ohio miles. I have not removed the intercooler yet but the bottom section appears to be visually open where it was crimped, so I am guessing it is just a boost leak on the intercooler. Part is coming Friday so I will replace it soon.
 

·
Registered
Joined
·
20 Posts
Discussion Starter · #6 ·
Yes its ur intercooler mine came un crimped so we just crimped it back up and everything is good now 😁
 

·
Registered
Joined
·
20 Posts
Discussion Starter · #7 ·
So just had my car on the dyno today and with the stock intercooler and a 4th gear pull made 205hp then we put the wagner tuning IC in and it made 236hp well worth it to get the wagner tuning intercooler from the k5 Optima store 30hp gain
 

·
Registered
2011 Kia Optima
Joined
·
3,387 Posts
A larger intercooler isn't going to increase HP, especially when looking at 31. With the very low stock RW HP reading of 205, the OEM cooler was probably leaking. With 274HP and drivetrain loss of, let's say 15%, should have seen @ 233 when stock.
 

·
Registered
Joined
·
20 Posts
Discussion Starter · #10 ·
No dude it wasn’t leaking at all with no codes bro i have the proof and i seen it with my own eyes buddy 👍
 

·
Registered
Joined
·
20 Posts
Discussion Starter · #12 ·
That 274hp is at the crank and the only way I pulled 263hp was when it shifted into 5th gear
 

·
Registered
2011 Kia Optima
Joined
·
3,387 Posts
31hp gain
Never happen with just the intercooler!
I'll now ask you two questions, why the RW HP was so low when on the dyno, and how do you get 31 HP with just the intercooler? Actually with the new intercooler you're back to stock levels.

Read the following, first one I saw, dyno w/ 91 octane as some say a 6-8 HP gain, 234 stock and if I give them the 8hp, 226 STOCK.

I could look up more, but no time
 

·
Registered
2018 Kia Optima
Joined
·
1,147 Posts
Post the pre-Wagner IC dyno chart; I'm not gonna diisagree with your 31-hp increase claim, just curious as to what RPM the stock HP reading was taken. What's also interesting is that in the Wagner dyno chart the torque starts to drop and keeps steadily dropping after ~2K RPM, whereas in comparison the stock Sonata GLS in the Edmunds link has a much flatter torque curve. Guess something has to give when it comes to trying to squeeze out more HP...
 

·
Premium Member
2012 Kia Optima
Joined
·
51 Posts
Well I can confirm P0299 for was also caused by a bad intercooler. Bottom of it separated just like others have reported. I bought a brand new one from RockAuto for about $190 and was back to full power. Install for me taking the front bumper off for the first time was about 4 hours. Glad I did it myself.
 

·
Registered
2012 Black SX Prem. & Tech.
Joined
·
2,184 Posts
Did anyone have a picture showing the separation when the crimping failed, or a picture showing how it goes back together and how you recrimped it?
 
1 - 18 of 18 Posts
Top