Kia Optima Forums banner
1 - 8 of 8 Posts

·
Registered
Joined
·
9 Posts
Discussion Starter · #1 ·
So I got my gauge installed ,, but the dial barely moves ,, not sure if I hooked the air hose in the wrong place,,, 2015 kia optima sxt gdi
248777
248778
 

·
Registered
2013 Kia Optima
Joined
·
562 Posts
Why are you using an analog gauge? Use an OBDII Monitor, and an app like Torque, you'll get far better results.
 

·
Registered
Joined
·
9 Posts
Discussion Starter · #3 ·
Tbh i seen a YouTube video with a turbo gauge on the same car as mine ,, so I wanted to do it , his worked ,, mine only hits up to 0 ,,, 😡
 

·
Registered
2013 Kia Optima
Joined
·
562 Posts
Well, good luck... The only thing I can suggest is ensure your vacuum lines are oriented correctly. And try reversing them.
 

·
Registered
2018 KIA Optima
Joined
·
197 Posts
If I'm seeing it properly.. the place you tied into... isnt using clamps.. therefore isnt holding boost. So you might have created a boost leak.. or that is vaccum. That doesn't require clamps most the time

also
If your ever modding your car, the obd2 scanner tools might not be accurate. And it looks like you ment to tie into the other side of that sensor. Where the clamps are. That might be boost..
 

·
Registered
Joined
·
9 Posts
Discussion Starter · #7 ·
Yea I'm pretty positive I cut the wrong hose where I placed that 3 way at ,,,, it should of been installed on the hose right on the bov,, I messed up , now gotta figure out how to fix that hose I cut
 

·
Registered
Joined
·
9 Posts
Discussion Starter · #8 ·
If I'm seeing it properly.. the place you tied into... isnt using clamps.. therefore isnt holding boost. So you might have created a boost leak.. or that is vaccum. That doesn't require clamps most the time

also
If your ever modding your car, the obd2 scanner tools might not be accurate. And it looks like you ment to tie into the other side of that sensor. Where the clamps are. That might be


Yea I'm pretty positive I cut the wrong hose where I placed that 3 way at ,,,, it should of been installed on the hose right on the bov,, I messed up , now gotta figure out how to fix that hose I cut
 
1 - 8 of 8 Posts
Top