Kia Optima Forums banner
1 - 9 of 9 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter · #1 ·
Hey, I have a 2011 Kia Optima. First problem that occurred was my car battery posts were lose and I would have to wiggle them to make the car start. Eventually that stop being the issue. It developed to all my lights being on on the dash, but my car would not start over! It basically would start when it wants too! Sometimes I would notice that my lights in my car would appear dim, I would jump my car and there you have it it starts (this method only works if my lights are Dim). I took it to the mechanic he said my starter, battery, and alternator are all in good standing. He changed my battery post. But I’m still have the same problem.
That’s not it. Yesterday I hit a really bad pot hole that hit underneath my car really hard. As I kept driving home. I start hearing a strange sound and my car started driving differently. As I kept driving my rpm was going up my acceleration was hesitant! Then it transitioned to my rpm going all the way up and my car only going 20 mph. To eventually not moving at all! I had to get it towed home. Can anyone help me out please! With either problem, did I knock something off tract under my car like the transmission or a oil pan, or a sensor?
 

·
Registered
2013 Kia Optima
Joined
·
178 Posts
Hey, I have a 2011 Kia Optima. First problem that occurred was my car battery posts were lose and I would have to wiggle them to make the car start. Eventually that stop being the issue. It developed to all my lights being on on the dash, but my car would not start over! It basically would start when it wants too! Sometimes I would notice that my lights in my car would appear dim, I would jump my car and there you have it it starts (this method only works if my lights are Dim). I took it to the mechanic he said my starter, battery, and alternator are all in good standing. He changed my battery post. But I’m still have the same problem.
That’s not it. Yesterday I hit a really bad pot hole that hit underneath my car really hard. As I kept driving home. I start hearing a strange sound and my car started driving differently. As I kept driving my rpm was going up my acceleration was hesitant! Then it transitioned to my rpm going all the way up and my car only going 20 mph. To eventually not moving at all! I had to get it towed home. Can anyone help me out please! With either problem, did I knock something off tract under my car like the transmission or a oil pan, or a sensor?
I used to have a problem that it wouldn't start in park but it would start in neutral. the other thing you would have to have a check engine light on.
 

·
Registered
Joined
·
5 Posts
Discussion Starter · #4 ·
I used to have a problem that it wouldn't start in park but it would start in neutral. the other thing you would have to have a check engine light on.
Thank you, I will sure give that a try! Yes my check engine is on as well.
 

·
Registered
Joined
·
28 Posts
Yesterday I hit a really bad pot hole that hit underneath my car really hard. As I kept driving home. I start hearing a strange sound and my car started driving differently. As I kept driving my rpm was going up my acceleration was hesitant! Then it transitioned to my rpm going all the way up and my car only going 20 mph. To eventually not moving at all! I had to get it towed home.
You cracked the transmission pan and all the fluid eventually leaked out.
 

·
Registered
Joined
·
5 Posts
Discussion Starter · #7 ·
You cracked the transmission pan and all the fluid eventually leaked out.
Is that an expensive fix? I have an appointment with Kia this morning and they said I have a recall on my engine, so if they suspect that I need a new engine then it is covered under warranty, and I get the service for free! I’ll ask them to fix the transmission pan as well. Thank you!
 

·
Registered
Joined
·
28 Posts
Maybe $100 for new pan and gasket, $75 for fluid $150 for labor. Just hope the transmission wasn't damaged from running dry. I would have taken it to an independent shop to replace the pan. Now Kia can claim abuse if they see a cracked pan and could deny warranty on the engine.
 

·
Registered
Joined
·
5 Posts
Discussion Starter · #9 ·
You are so right! Kia called and said my car is in bad shape. They said I cracked my transmission. So eventually I would need a new one. They said I need a new battery( which I really think that isn’t the case the last mechanic checked on everything and changed my battery post, prior to I also got my battery checked at autozone, and it was a great battery). The said my suspension is bad as well. The total cost of everything overall is roughly around $4500 which is a new car. They said they can get my car to run and the cost is $280, to get a new battery, plus the diagnostic fee. Of course when I asked if I qualified for a new engine they denied me. At this point I really just don’t know.
 
1 - 9 of 9 Posts
Top