Kia Optima Forums banner
1 - 4 of 4 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
So from start bought 2013 kia optima ex nov 2019 65k on it brand new tires, for total of 14,000 feb 2020 started having small transmission issues of slipping and getting stuck in 4th gear but once I turn car off let it sit for a bit back to normal. took to kia 10x no check engine light no codes nothing said nothing they could do without codes so pay the service fees which rack up, finally they open a cat case on it do all kinds of test comes back my catalytic converter was bad it was breaking apart on the inside and manifold cracked got that replaced in August of 2020 had oil change done inspection says My tires were in great shape no issues get car back drove off lot stuck in 4th gear again sent it back kept rental car and finally a code popped up needs a new transmission well thats what I told them for months.. finally got got car back in Sept 2020 from New transmission put in noticed end of nov 2020 my tires were wearing thin take in for another oil change dec 2nd after 2900 miles from last oil change they say I need alignment and new tires. Wth **** man. They were basically brand new well. that night my car stalls on me while driving no check engine no nothing and won't restart.. get it home let it sit over night try starting again next morning dec 3 2020 engine is locked up.. dec 3rd have car towed to kia.. took them 6 days to get me a rental car missed a couple days of work.. everytime I take my car to be fixed something else breaks its ridiculous in 4 months time a new manifold, new catalytic converter, new transmission, and now new engine. Oh and my window motors are failing car with only has 78k miles on it... agghh everytime I take the car in for a repair something else breaks..
 

·
Registered
2012 Black SX Prem. & Tech.
Joined
·
2,194 Posts
Is there another Kia dealership you could try for service? Maybe you are not getting the best service where you go now.

Also, I don't see how the tires wearing early could be a problem with the car, unless the alignment is off, but that's due to maintenance, not an inherent design problem.
 

·
Registered
Joined
·
2 Posts
Discussion Starter · #3 ·
I was meaning as inmy alignment and tires were just fine till my car went in to be repaired and after cat, manifold and transmission was replaced my alignment got messed up and oh yea my cruise control stopped working
 

·
Registered
2012 Black SX Prem. & Tech.
Joined
·
2,194 Posts
Sounds like you have several symptoms of receiving bad service. To fully diagnose, you might try going to a very trusted mechanic friend, and see if suddenly your issues resolve.
 
1 - 4 of 4 Posts
Top