Kia Optima Forums banner

261 - 280 of 283 Posts

·
Your K5 Optima Vendor
2020 Audi R8 V10+ & Tesla Model X P100D
Joined
·
28,952 Posts
Discussion Starter #261
2016 Kia Optima SX TURBO here. Quick question, I'm thinking about doing this whole LAP3 mod because who doesn't want to go faster if they can.

Current mods-
KINETIC CAT BACK EXHAUST
AEM CAI
HKS BOV

My first question is, being that the car is new and only has around 3,000 miles on it should I wait till I put a little more age on the engine before chipping it?

Second question is, being that I also have a remote starter that was installed on vehicle by dealer is there a possibility of me messing with how that functions if I do the whole battery/ecu reset? I don't want to lose that because I paid a decent penny for that set up as you could imagine.

All responses are appreciated!
Nice mod list, you will not have any issues running the LAP3 chip we sell with those mods.

As far as adding the chip with only 3,000 miles on the car, that would not be an issue, however you can wait to get a bit more mileage if you feel safer that way.
No in regards to the remote starter you currently have, the LAP3 chip would play no affect in that. The battery reset procedure to clear the ECU would should not affect the remote start in any way.
 

·
Your K5 Optima Vendor
2020 Audi R8 V10+ & Tesla Model X P100D
Joined
·
28,952 Posts
Discussion Starter #263
Does the LAP3 chip require a dual catch can setup or just pcv catch can?
Running the LAP3 Uncle Chip does not *require* the usage of any catch cans, however we highly recommend a minimum of at least one on the PCV side. Having 2 OCC's is just an extra measure to protect the longevity of the motor.
 

·
Registered
2012 Kia SX GDI
Joined
·
8 Posts
JUST PURCHASED UNCLE CHIP! I'm so excited to get this mod! Plug n play, are you kidding me! I've heard nothing but the best of things! Come to papa! 2012 Kia Optima SX 2.0 T Vrooooooom!!!!!
 

·
Your K5 Optima Vendor
2020 Audi R8 V10+ & Tesla Model X P100D
Joined
·
28,952 Posts
Discussion Starter #265
JUST PURCHASED UNCLE CHIP! I'm so excited to get this mod! Plug n play, are you kidding me! I've heard nothing but the best of things! Come to papa! 2012 Kia Optima SX 2.0 T Vrooooooom!!!!!
Thank you for placing your order with us online!
 

·
Registered
Kia Optima SXL / Sorento SX
Joined
·
130 Posts
Bought the LAP3 a few months. Awesome! Tons of extra power. Bought the colder plugs and OCC too. Everything is awesome. However...

Yesterday morning driving home. Around 80% throttle, in 2nd gear, I heard a series of knocks and bangs coming from the motor. Doesn't sound good at all. Once I let off the throttle, it went away. Took the LAP3 out, doesn't seem to happen. Put LAP3 back in, it seems to be happening again. But only at around 80-100% throttle.

Is this motor trouble? Or could this be octane / timing issue? the LAP3 is setup for 93 octane. Wondering if I should set to 89 and see if knock goes away?

Again... the knock only seems to happen at 80-100% throttle. Wondering if this a motor / rod issue that is only brought on by the additional power. Or... could this be a timing / knock issue?

Any feedback or experience of similar would be greatly appreciated. Hate to take this LAP3 out... I'm having so much fun with it. :)
 

·
Your K5 Optima Vendor
2020 Audi R8 V10+ & Tesla Model X P100D
Joined
·
28,952 Posts
Discussion Starter #267
Bought the LAP3 a few months. Awesome! Tons of extra power. Bought the colder plugs and OCC too. Everything is awesome. However...

Yesterday morning driving home. Around 80% throttle, in 2nd gear, I heard a series of knocks and bangs coming from the motor. Doesn't sound good at all. Once I let off the throttle, it went away. Took the LAP3 out, doesn't seem to happen. Put LAP3 back in, it seems to be happening again. But only at around 80-100% throttle.

Is this motor trouble? Or could this be octane / timing issue? the LAP3 is setup for 93 octane. Wondering if I should set to 89 and see if knock goes away?

Again... the knock only seems to happen at 80-100% throttle. Wondering if this a motor / rod issue that is only brought on by the additional power. Or... could this be a timing / knock issue?

Any feedback or experience of similar would be greatly appreciated. Hate to take this LAP3 out... I'm having so much fun with it. :)
Hey Brian,

Glad to hear you have been loving this product. I would be more than happy to help you with this issue, as it most likely is related to the spark plugs themselves, and not the LAP3 chip.

Can you please email us directly for the quickest response, or even give us a call here so we can help troubleshoot this with you?

[email protected] or 213-785-7512
 

·
Registered
2015 Kia Optima
Joined
·
236 Posts
Bought the LAP3 a few months. Awesome! Tons of extra power. Bought the colder plugs and OCC too. Everything is awesome. However...

Yesterday morning driving home. Around 80% throttle, in 2nd gear, I heard a series of knocks and bangs coming from the motor. Doesn't sound good at all. Once I let off the throttle, it went away. Took the LAP3 out, doesn't seem to happen. Put LAP3 back in, it seems to be happening again. But only at around 80-100% throttle.

Is this motor trouble? Or could this be octane / timing issue? the LAP3 is setup for 93 octane. Wondering if I should set to 89 and see if knock goes away?

Again... the knock only seems to happen at 80-100% throttle. Wondering if this a motor / rod issue that is only brought on by the additional power. Or... could this be a timing / knock issue?

Any feedback or experience of similar would be greatly appreciated. Hate to take this LAP3 out... I'm having so much fun with it. :)
Sounds like spark knock/detonation. I had the same thing on the 93 setting, although we only get 91 octane fuel here. It would only happen at the shifts from one gear to the next (1-2 or 2-3 mostly). I set it back to the 91 octane setting (7-5-5), and no more knock with the same fuel.
 

·
Your K5 Optima Vendor
2020 Audi R8 V10+ & Tesla Model X P100D
Joined
·
28,952 Posts
Discussion Starter #269
Sounds like spark knock/detonation. I had the same thing on the 93 setting, although we only get 91 octane fuel here. It would only happen at the shifts from one gear to the next (1-2 or 2-3 mostly). I set it back to the 91 octane setting (7-5-5), and no more knock with the same fuel.
After speaking with the customer on the phone, I believe he had two variables that may have been causing the issue.

If I remember correctly, the main problem was the spark plugs were not checked or gapped prior to installing them on the vehicle.

Even though they are supposed to come out of the box set to 0.028, when shipping from Japan (HKS Headquarters) to the EastCoast (HKS US Distributor), then to the WestCoast (K5 Optima Store), and then to the customer, they can become off on the gap setting.

Therefore, we have had many customers reporting the gap on the plugs to be anywhere from 0.023 - 0.036 out of the box. If run for extended periods of time this way, it can cause the plug to become fouled or even damaged. It will also cause the engine to not run correctly as it is not getting the correct spark from the plugs. We have had several customers report that the insulator sleeve came loose and damaged the plugs after running them for an extended period with the wrong gap.

Also the gasoline quality being used on the vehicle is very important as well. Even though I have had many friends and acquaintances tell me that all gas comes from the same place and is the same quality, I know for a fact that this is not accurate as each individual gas station mixes in their own octane boosters and what not. Any gas station I have ever come across that ends with an "O" seems to have been crap for quality. (With the exception of Costco from what I've seen)

Arco, Valero, Texaco, are all gas stations we DO NOT recommend using when running any performance tune. We only recommend using gas stations like Shell, Chevron, 76 or Mobil. If the quality of the gas and octane being used on the vehicle when running the tune is not good enough, the engine will knock from detonation and yes, by turning the setting on the chip/tune down, it will prevent that from happening.
 

·
Registered
2013 SXL
Joined
·
58 Posts
Heavily considering this chip, already have an OCC and a body spacer. One question - is an BOV recommended to let off extra boost? Any harm in not having one? I only have a sound plate and don't really care to have the noise of either at this point (just personal preference) Thanks!
 

·
K5 Optima Store Vendor
Santa Fe/350z
Joined
·
726 Posts
Heavily considering this chip, already have an OCC and a body spacer. One question - is an BOV recommended to let off extra boost? Any harm in not having one? I only have a sound plate and don't really care to have the noise of either at this point (just personal preference) Thanks!
No harm, but a true BOV like the HKS we carry, will do a more effective and efficient job releasing the increased boost.
 

·
K5 Optima Store Vendor
Santa Fe/350z
Joined
·
726 Posts
The one & only LAP3 Uncle Chip Performance Tune!

Available for all newer models of Kia & Hyundai equipped with a factory turbocharger.

With over 500 of these sold already to date, we can confirm this product is no joke.

With a 100% Plug & Play 10 minute installation, you'll be making power in no time at all!

Don't take our word for it, checkout some of the 100+ 5 star reviews on our site of the product.

Read reviews and/or order the product on our site here

Also be sure to checkout all of our threads in our subforum here on the site below:

Optima Forums - K5 Optima Store - Sub Forum - All threads

 

·
K5 Optima Store Vendor
Santa Fe/350z
Joined
·
726 Posts
The one & only LAP3 Uncle Chip Performance Tune!

Available for all newer models of Kia & Hyundai equipped with a factory turbocharger.

With over 500 of these sold already to date, we can confirm this product is no joke.

With a 100% Plug & Play 10 minute installation, you'll be making power in no time at all!

Don't take our word for it, checkout some of the 100+ 5 star reviews on our site of the product.

Read reviews and/or order the product on our site here

Also be sure to checkout all of our threads in our subforum here on the site below:

Optima Forums - K5 Optima Store - Sub Forum - All threads

 

·
Registered
2014 KIA Optima (Snow White Pearl)
Joined
·
139 Posts
Just copying my comments from my showroom for more visibility. Installed the plugs, OCC and Uncle Chip a few weeks back. Still haven't had a chance to dyno the car but I'm really enjoying the **** out of this chip. I switched over to 93 octane from a Shell station and I can feel a definite improvement since my last tank. Now that the cooler weather has finally arrived, the car really seems to have a completely different feel to it - and I'm actually getting better gas mileage. From a dead stop, the car can really squeal the tires and I have a tough time making the tires stick. When rolling at low speed like 25-30mph, the car really takes off when the pedal is hammered. When at full freeway speed, the car effortlessly pulls away and a 10 mph jump from 70-80mph feels like nothing. It's actually a little crazy how the car accelerates at higher speeds - all of the sudden you are doing 20Mph over without realizing it. And that's in NORMAL driving mode! When I switch to Sport mode, the car turns into a hungry beast after 2000 RPM and the acceleration puts you back in your seat.I did have one weird issue where the car didn't start on the first turn, and I had to basically put the shifter back in park and try again. I noticed the car started just fine on the second round but it was like the turbo was not functioning. I couldn't feel any boost all and no vent-to-atmosphere noise - the car was basically in limp mode. I turned the car off and back on again and everything was back to normal - it was a one-time thing but I have no idea what the root cause was.Anyway, money well spent between the plugs and chip. Really diggin the setup! Anyone who is on the fence about this, take the plunge - it's seriously hard NOT to mash the pedal everywhere you go. :)
 

·
Your K5 Optima Vendor
2020 Audi R8 V10+ & Tesla Model X P100D
Joined
·
28,952 Posts
Discussion Starter #275
Just copying my comments from my showroom for more visibility. Installed the plugs, OCC and Uncle Chip a few weeks back. Still haven't had a chance to dyno the car but I'm really enjoying the **** out of this chip. I switched over to 93 octane from a Shell station and I can feel a definite improvement since my last tank. Now that the cooler weather has finally arrived, the car really seems to have a completely different feel to it - and I'm actually getting better gas mileage. From a dead stop, the car can really squeal the tires and I have a tough time making the tires stick. When rolling at low speed like 25-30mph, the car really takes off when the pedal is hammered. When at full freeway speed, the car effortlessly pulls away and a 10 mph jump from 70-80mph feels like nothing. It's actually a little crazy how the car accelerates at higher speeds - all of the sudden you are doing 20Mph over without realizing it. And that's in NORMAL driving mode! When I switch to Sport mode, the car turns into a hungry beast after 2000 RPM and the acceleration puts you back in your seat.I did have one weird issue where the car didn't start on the first turn, and I had to basically put the shifter back in park and try again. I noticed the car started just fine on the second round but it was like the turbo was not functioning. I couldn't feel any boost all and no vent-to-atmosphere noise - the car was basically in limp mode. I turned the car off and back on again and everything was back to normal - it was a one-time thing but I have no idea what the root cause was.Anyway, money well spent between the plugs and chip. Really diggin the setup! Anyone who is on the fence about this, take the plunge - it's seriously hard NOT to mash the pedal everywhere you go. :)
Thank you for sharing this review here on the product page of the forum for others to see. We appreciate your business, and am happy you are enjoying the power increase from the chip.
 

·
Your K5 Optima Vendor
2020 Audi R8 V10+ & Tesla Model X P100D
Joined
·
28,952 Posts
Discussion Starter #276
Looking for that extra power increase on your Optima turbo?

Then look no further, we have this in stock and ready to ship out!

(Christmas/New Years Sale Staring this weekend)

If anyone has any questions about this product or any of the products we sell, please don't hesitate to reach out to us anytime

[email protected]
 

·
Registered
2013 Optima
Joined
·
4 Posts
Actually glad I missed the Christmas sale this year, but my plugs are due to be replaced in about 12k miles so next Christmas I'll be ordering plugs and the chip.

This Christmas I went with the ADD1 V3 catch can as a first step. Going to be hard to wait a whole year...
 

·
K5 Optima Store Vendor
Santa Fe/350z
Joined
·
726 Posts
Actually glad I missed the Christmas sale this year, but my plugs are due to be replaced in about 12k miles so next Christmas I'll be ordering plugs and the chip.

This Christmas I went with the ADD1 V3 catch can as a first step. Going to be hard to wait a whole year...
Still a great choice! The new design of the V3 catch cans really helps cut down on unwanted vapors getting into the engine
 
261 - 280 of 283 Posts
Top