Kia Optima Forums banner
1 - 9 of 9 Posts

·
Registered
Joined
·
7 Posts
Discussion Starter · #1 ·
hey guys, if someone could help me out please I feel like I've tried everything.

My car started out running rough, but it was quiet. I drive an hour to and from work 5 days a week. I got the car at 35k and it is currently 90k.
The rough idling has gotten worse, and I started by replacing the plugs 3 months ago. I looked at them recently and they had black on them, so I assumed that was causing the problem and I just replaced both O2 sensors. Its gotten worse since then and I checked them and they were installed properly.
I have also replaced all 4 coils. I cannot remember if this issue started before or after I installed the plugs. Could a new plug be bad?
Or is it something else? It is more rough when I push on the gas, but is rough altogether no matter whether in park or driving. Its just louder when driving.
 

·
Registered
Joined
·
3 Posts
Have you tried cleaning the intake valves and throttle body I bout 2018 optima ex with 30k miles had noticed the rpm would jump up and down sometimes at a stop light like the car would almost want to die. So I looked into and found this product and the issue went away. And also help with gas milage.



Sent from my iPhone using Tapatalk
 

·
Registered
2011 Kia Optima
Joined
·
3,395 Posts
No CEL? What type of plugs did you install? Check vacuum lines, take a compression test.
Probably don't have the app, but check real time data through the OBDII port.
 

·
Registered
2012 Black SX Prem. & Tech.
Joined
·
2,191 Posts
Also check the engine air filter - really quick, no tools needed.

Another item could be the fuel filter or fuel pump?

Long shot: check the fuel cap, maybe it's creating too much of a vacuum. But you'd notice this based on your fuel level (where it would worsen the less fuel you had left in the tank).
 

·
Registered
Joined
·
7 Posts
Discussion Starter · #5 ·
I have not tried cleaning the intake valves and throttle body.
I put the same spark plugs in it that I would've bought at the dealership, but I got them cheaper at Autozone. And no sadly no check engine light. I have someone who has one of those expensive scanners but he won't do anything until the check engine light comes on.
I did replace the air filter. And the fuel filter and fuel pump are pretty expensive but I've definitely thought about it.
UPDATE
I have an appointment with kia next Wednesday for them to check my engine and engine block for free since that lawsuit made my engine have a lifetime warranty. If they don't fix it (meaning its not the engine) then I will try everything you guys mentioned.
.
If anyone else wants to comment with any other ideas I'm 100% open and will start trying things after my appt with kia.
 

·
Registered
2011 Kia Optima
Joined
·
3,395 Posts
Never heard of a dealershiop check the engine for recall problem and if no indication, do testing free of charge, so better make certain that if the engine is not the problem (recall) you don't have a bill waiting for you.
 

·
Registered
Joined
·
7 Posts
Discussion Starter · #7 ·
Never heard of a dealershiop check the engine for recall problem and if no indication, do testing free of charge, so better make certain that if the engine is not the problem (recall) you don't have a bill waiting for you.
I will definitely watch, but I had them check it once and they claimed it was my tires supposedly and they let me leave for free when there was no warranty.
I've had a dealership try to screw me over once, I get what you're saying 100%.
It was Celebration Kia in Dublin
 

·
Registered
Joined
·
89 Posts
hey guys, if someone could help me out please I feel like I've tried everything.

My car started out running rough, but it was quiet. I drive an hour to and from work 5 days a week. I got the car at 35k and it is currently 90k.
The rough idling has gotten worse, and I started by replacing the plugs 3 months ago. I looked at them recently and they had black on them, so I assumed that was causing the problem and I just replaced both O2 sensors. Its gotten worse since then and I checked them and they were installed properly.
I have also replaced all 4 coils. I cannot remember if this issue started before or after I installed the plugs. Could a new plug be bad?
Or is it something else? It is more rough when I push on the gas, but is rough altogether no matter whether in park or driving. Its just louder when driving.
Could be a bad coil, but then you should get a cel too:rolleyes:
 

·
Registered
Joined
·
7 Posts
Discussion Starter · #9 ·
Alright I finally have an update!
Took it to Kia, they finally heard the noise I was hearing and they updated the system and told me to run a full tank of premium through it. If it is still making the noise they told me to please come back and make another appointment. I didn't pay anything during my visit.
I'm guessing if this doesn't work they're gonna replace the engine because of that recent class action lawsuit.
It is still making the noise after 1/4 a tank of premium used.
 
1 - 9 of 9 Posts
Top