Kia Optima Forums banner
1 - 20 of 54 Posts

·
Registered
2012 Black SX Prem. & Tech.
Joined
·
2,184 Posts
Discussion Starter · #1 ·
Just got a letter today from KIA about how they are extending warranty to cover the steering coupler replacement. Anyone else get one yet? Sorry if this is old news, but my letter just arrived today.
 

·
Registered
2014 Kia Optima
Joined
·
92 Posts
I got one for my 2013 SX yesterday. Since I no longer have it, i just checked the box as sold and dropped the card in the mail. I haven't received a letter for my current car yet. To my understanding, it's only for some 2014 optima models. I'm going to call KIA Monday and see what's up with that.
 

·
Premium Member
2012 Kia Optima SX-T
Joined
·
1,456 Posts
Just got a letter today from KIA about how they are extending warranty to cover the steering coupler replacement. Anyone else get one yet? Sorry if this is old news, but my letter just arrived today.
Got mine in the mail yesterday. Since I'm not in the "High Humidity" states, I don't get an automatic free replacement but I do get the warranty extended to 10 years and unlimited miles for this issue. I'm fine with that. If the issue shows up in the 10 years of ownership, it's covered by the warranty.
 
  • Like
Reactions: JasonS and Usnswc

·
'MURICA
2013 Kia Optima
Joined
·
114 Posts
It seems we all got this letter yesterday or the past week. It'll go in the glove box where the engine warranty went as requested.
 

·
01/2015 ROTM, 05/2015 ROTM
2013 Optima 2013 SXL
Joined
·
1,145 Posts
So I know there is a TSB and free service on this dreaded steering coupler. But I never take my car anywhere near the stealership unless its ABSOLUTELY necessary. I had a slight clunk in the steering a while back and checked the coupling and it seemed OK. Should have changed it out then as it was probably beginning to soften. Anyway, a few months later and the problem got worse...pulled it apart today and..OH yeh....its fried !!..what a crappy design !!..seems like the rubber just turns to mush !!! There is no way I would have trusted my local dealer to do this with all the extra wiring I have down there for my Canbus module etc.

DSC02216.jpg
 

·
Registered
2013 Kia SX
Joined
·
505 Posts
Wow julio that is crazy. I just did one on Thursday under the new warranty extension. Since I'm in jersey they don't melt and break apart like that but they get dry and clunk when making turnsbut that pic is amazing to see down in florida. They are fairly easy to replace as well, only takes me about a half hour start to finish
 

·
01/2015 ROTM, 05/2015 ROTM
2013 Optima 2013 SXL
Joined
·
1,145 Posts
Wow julio that is crazy. I just did one on Thursday under the new warranty extension. Since I'm in jersey they don't melt and break apart like that but they get dry and clunk when making turnsbut that pic is amazing to see down in florida. They are fairly easy to replace as well, only takes me about a half hour start to finish
Yeh,it was a nasty stick mess in there ! no offence to the Kia techs on here, I am sure there are some great ones. Unfortunately, I have not had good experiences with my local dealers, so I try and do most of my own maintenance.
 

·
Registered
2013 Kia SX
Joined
·
505 Posts
)
Yeh,it was a nasty stick mess in there ! no offence to the Kia techs on here, I am sure there are some great ones. Unfortunately, I have not had good experiences with my local dealers, so I try and do most of my own maintenance.
Honestly, can't blame you as most "techs" we hire are a bunch of hacks or kids that don't have a clue what they are doing.

---------- Post added at 10:22 PM ---------- Previous post was at 04:14 PM ----------

I'm curious thinking about it now, julio did you have any drivability issues like hard steering as well?
 

·
01/2015 ROTM, 05/2015 ROTM
2013 Optima 2013 SXL
Joined
·
1,145 Posts
)

Honestly, can't blame you as most "techs" we hire are a bunch of hacks or kids that don't have a clue what they are doing.

---------- Post added at 10:22 PM ---------- Previous post was at 04:14 PM ----------

I'm curious thinking about it now, julio did you have any drivability issues like hard steering as well?
Not that I noticed, the side to side "clunk" just got more pronounced.

---------- Post added at 07:46 AM ---------- Previous post was at 07:41 AM ----------

Is there a way to tell if that piece is going bad? Or you wont really know until it breaks?
You will notice you begin to get a "clunk" when you turn the steering wheel from side to side . It gets worse as the coupler breaks down more. The first time I noticed I was getting it and took the steering motor off , the coupler still looked OK and i did not replace it as i thought the problem must be elsewhere. But they obviously begin to degrade before they show any obvious signs of wear.By the time i removed it a second time, it had literally turned to "mush". I do live in a very humid climate though (FL) which supposedly accelerates the problem.
 

·
Registered
2011 Kia Optima
Joined
·
66 Posts
I just got a slight clunk while turning today. Have to make a call for an appointment at the dealer.
SnowWhite, I see you're in North Jersey, where about?
 

·
Registered
2013 Kia SX
Joined
·
505 Posts
Not that I noticed, the side to side "clunk" just got more pronounced.

---------- Post added at 07:46 AM ---------- Previous post was at 07:41 AM ----------



You will notice you begin to get a "clunk" when you turn the steering wheel from side to side . It gets worse as the coupler breaks down more. The first time I noticed I was getting it and took the steering motor off , the coupler still looked OK and i did not replace it as i thought the problem must be elsewhere. But they obviously begin to degrade before they show any obvious signs of wear.By the time i removed it a second time, it had literally turned to "mush". I do live in a very humid climate though (FL) which supposedly accelerates the problem.
All the couplers I've replaced so far haven't looked bad but when you remove them, at least here, the little nipples are usually worn down that the new ones have
 

·
Registered
2011 Kia Optima LX
Joined
·
110 Posts
Does this also effect our Korean built 2011 Optima's as well????
I have a 2011 LX and I live in Guam, and yes we have lots of Ocean and Humidity here....
 

·
Registered
2011 Kia Optima
Joined
·
250 Posts
Does anyone have a phone number that was included in this recall? I submitted my recall a few months ago for reimbursement. They said it would take three weeks to hear anything, been a few months now.
 

·
Premium Member
2012 Kia Optima SX-T
Joined
·
1,456 Posts
Got mine in the mail yesterday. Since I'm not in the "High Humidity" states, I don't get an automatic free replacement but I do get the warranty extended to 10 years and unlimited miles for this issue. I'm fine with that. If the issue shows up in the 10 years of ownership, it's covered by the warranty.
Well, I found mine was getting worse as the colder temperatures hit, so I went to my local dealership this morning and had them inspect/test the steering column linkage, rack and pinion and inspect/replace the MDPS flexible steering coupler (under warranty). Only the steering coupler was bad and was covered under warranty (I had my letter with me). They worked me in and had me done in 1.5hrs. Excellent customer service. Steering feels much better now (like new)!

Here is a picture of the old coupler:

 

·
Registered
Joined
·
328 Posts
I had this repair done under warranty within the past month. Had the "clunk" noise when turning the steering wheel, dealer said it was a very common problem.
 

·
Registered
2014 Kia Optima
Joined
·
92 Posts
I had the whole steering column replaced the other day. I went in for that underbody spray and 20 minutes later the SA came over and told me the tech heard an irregular rubbing noise when turning into the bay and he was going to look at it. An hour or so later she came back and said my steering column was defective and that they we're going to replace it. I told her it was steering just fine and I haven't heard any noise coming from there. They fixed it under warranty. Thankfully they had the part in stock and was fixed that day.
 

Attachments

1 - 20 of 54 Posts
Top