Kia Optima Forums banner
1 - 4 of 4 Posts

Registered
Joined
34 Posts
Discussion Starter · #1 ·
On the highway yet again headed out to a city, about an hour drive.....same as before, not pushing the car but up in the 85mph area, speed lim is 70. Keep in mind just like my previous 2 engines, i haven't even reached my first oil change, current engine was put in at 105k and car is currently 106k....nearing 107k. Outta nowhere while on highway, i lose power and start misfiring like crazy, i have changed everything from coils, cleaned map sensor, changed spark plugs constantly, even brought it to dealership for diagnosis they said (car runs fine they didn't find anything) ....before that i took it to dealership that put 3rd engine in because cylinder 2 got a new fuel injector put in along with the 3rd engine, told them i had the slight misfire thinking it was a simple injector leak and they just said theyd do an injector clean. After service they said it was 1qt low on oil as well.....so something had to be wrong with this (remanufactured engine). Now back to current situation......luckily i was able to make it home 35-40min drive keeping it 45mph and under. Gonna call kia up and demand a new not refurbished engine soon (highly unlikely considering its a 2013) but I'll settle for refurbished.....which in turn im definitely going to sell the vehicle after
 

Registered
2015 Kia Optima
Joined
207 Posts
Your car needs a FOURTH engine? Wow. This was my fear with the engine replacements (I've heard about people's second engine failure but not the third). I thought all the car engines were replaced with new ones because of the issues with the old ones? How'd yours end up with a refurbished one? You're less than 1k miles in on the third engine and it failed maybe the dealer isn't checking the car properly...
 

Registered
Joined
34 Posts
Discussion Starter · #3 ·
Yeah man first replacement was after driving off the 3rd party dealership i brought the car from. 10 minutes down the road my excitement turned to anger, engine seized entirely. The 3rd party dealership called Kia for some info trying to figure out issue, engine under recall...lifetime warranty so im happy, all is good. Engine goes out again while on highway headed up to Jacksonville but this time it doesn't seize, just a heavy misfire (this engine was probably best of them all). I pull over and shut it off.....I'll take a little of the blame because i was pushing it a bit on the highway 90mph.....but car gets up to 160, should be able to withstand that, especially if im keeping up with maintenance. (Keep in mind i haven't even done a single oil change on the car cuz it never lasts long enough). So i get the car towed and weeks later 3rd replacement at a different dealership they tell me since the previous dealer only changed engine and not turbo as well that it was the possible cause due to manufacturer mishap with debris in cylinders and etc......so they gave me a new turbo and replaced engine (105k on odo)(this is refurbished, they don't give brand new or would lose money). Now fast forward 1-2k miles today im yet again on the highway cruising and i accelerate on the on-ramp, reach about 85 to merge into far left lane and vuala, hard stutter so quickly let off gas then try to apply power again but its slowly decelerating. So considering i already know the issue at hand, i exit and take back roads straight home never exceeding 45-50mph. And here i am ranting at home ready to call kia tomorrow morning for another engine 馃槖. Thankfully im an essential so i also have to figure out how to get to work in the morning 馃檭(sarcasm).
 

Registered
2015 Kia Optima
Joined
207 Posts
Yeah man first replacement was after driving off the 3rd party dealership i brought the car from. 10 minutes down the road my excitement turned to anger, engine seized entirely. The 3rd party dealership called Kia for some info trying to figure out issue, engine under recall...lifetime warranty so im happy, all is good. Engine goes out again while on highway headed up to Jacksonville but this time it doesn't seize, just a heavy misfire (this engine was probably best of them all). I pull over and shut it off.....I'll take a little of the blame because i was pushing it a bit on the highway 90mph.....but car gets up to 160, should be able to withstand that, especially if im keeping up with maintenance. (Keep in mind i haven't even done a single oil change on the car cuz it never lasts long enough). So i get the car towed and weeks later 3rd replacement at a different dealership they tell me since the previous dealer only changed engine and not turbo as well that it was the possible cause due to manufacturer mishap with debris in cylinders and etc......so they gave me a new turbo and replaced engine (105k on odo)(this is refurbished, they don't give brand new or would lose money). Now fast forward 1-2k miles today im yet again on the highway cruising and i accelerate on the on-ramp, reach about 85 to merge into far left lane and vuala, hard stutter so quickly let off gas then try to apply power again but its slowly decelerating. So considering i already know the issue at hand, i exit and take back roads straight home never exceeding 45-50mph. And here i am ranting at home ready to call kia tomorrow morning for another engine 馃槖. Thankfully im an essential so i also have to figure out how to get to work in the morning 馃檭(sarcasm).
Dang man, sorry about this. Pushing at 90 MPH on the highway shouldn't cause it to misfire like that (Ours has been driven at 90-95 MPH plenty of times before). You probably aren't keen on giving the car another chance after this 4th engine..At least they are replacing it free of charge when it fails. The dealer give you a loaner car for work? (considering you are an essential worker).
 
1 - 4 of 4 Posts
Top