Kia Optima Forums banner

1 - 9 of 9 Posts

·
Registered
Joined
·
223 Posts
Discussion Starter #1
So for the last little while I have been having my Hybrid Wrench light come on indicating an issue. Took it into the dealer and the got a code that the battery had drained. Never in the 2+yrs that I have owned my car has the hybrid battery drained to empty. I have never ran out of gas so as to run down the hybrid battery. They told me to monitor and come back if it happens again. It did so I went in, this time no codes. They kept it for the day and couldn't find anything. Today I got the light so I drove to the dealer. They checked for codes and came back with 5. A few were Cam time out......, low voltage, battery low.. Should have wrote them down. Taking it back in Thursday for them to give it a good check over. Other than the light, you would never know there was an issue. Car drives like it did the day I bought it.
 

·
Registered
2011 Kia Optima
Joined
·
89 Posts
I had a 2003 Honda Civic Hybrid. I know that this will make no sense but I had a similar situation in 2010. I don't remember what the codes were but I had three of them including that my IMA battery was continually discharging. It ended up that the 12 volt battery had to be replaced even though it was testing out to be okay. Go figure!
 

·
Registered
Joined
·
223 Posts
Discussion Starter #3
I had a 2003 Honda Civic Hybrid. I know that this will make no sense but I had a similar situation in 2010. I don't remember what the codes were but I had three of them including that my IMA battery was continually discharging. It ended up that the 12 volt battery had to be replaced even though it was testing out to be okay. Go figure!
You were dead on. They say its the battery. Going to cost me $300, though I think i'll be sending an email to Kia. Batteries only be in use for 2yrs/2mths.
 

·
Registered
Joined
·
30 Posts
Interesting - I have been having the wrench light come on randomly for a while also... I've taken it in multiple times and every time they tell me they can't find any codes. Is there any good way to test the 12v battery? Since its a deep cycle - I don't know that a standard load test would be correct since it's not cranking anything over. Maybe throwing the battery on a trickle charger to make sure it's topped off would help?

As far as a replacement - I seem to remember that it's possible to put a cheaper and more readily available AGM battery in - like a yellow top. I just can't seem to find any info on it. Did you end up replacing the battery and have that solve the issue?
 

·
Registered
2006 Mercedes Benz 2006 E55 AMG
Joined
·
11 Posts
If the warning lamp came on, then there is a code somewhere. If you guys run in to trouble with hybrids shoot me some of your symptoms and trouble codes and I will do my best to let you know what to expect. I am Kia hybrid certified. Keep in mind, most all of the hybrid components fall under the 10/100 warranty so don't let a dealer give you the run around or try to charge you for new components. everything but some of the high voltage cables are covered I believe.
 

·
Registered
Joined
·
30 Posts
Thanks for the the assist offer! As far as symptoms there are none that I can tell - outside of the wrench light. It will just come on randomly and stay on until the car is re-started. One day the wrench and check engine lights came on at the same time. I tried running my OBD2 scanner on it and came back with nothing even in history codes. I'm guessing that my scanner can't get some codes that may be stored in other modules - but now I keep it in the car with me... Next time the light comes on I am going to try scanning while the light is on. I've also got a OBD-SX USB scanner but I don't think it gets me any more than my regular handheld scanner. I'm still actually under the bumper to bumper warranty as well - so they really have no excuse.
 

·
Registered
Joined
·
30 Posts
Still have to make an appointment at the dealer - but I got another wrench + check engine light. I tried my USB scanner this time and came up with a P0C17 - which seems hybrid specific. Not a whole lot of info on it comes up with Google - does anyone have experience with this code?
 

·
Registered
2013 Kia Optima Hybrid 2013 Kia Optima Hybrid ex
Joined
·
4 Posts
We are beyond the wrench, Started out having troubles with the acceleration, press gass and nothing happens, then RPM's rev up but transmission is not engaging, replaced the Throttle body, but Shop can not find any codes. Just drove home 40 miles from shop. 2 miles from home, got the message " Hybrid battery failure, turn off car and get it to a shop" it is as if the signal to go from battery to gas engine was not being sent.
 

·
Registered
Joined
·
1 Posts
My 12 v battery went out I had a local mechanic not the dealer replace it ever since then the wrench light has been on he pulled codes nothing the car is functioning fine but the light stays on. He even cleared it and it came back on. Any ideas on how to get it to go off without taking to dealer.
 
1 - 9 of 9 Posts
Top