Kia Optima Forums banner
1 - 2 of 2 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter · #1 ·
Hello guys,
I'm having a real rough time lately with my optima hybrid 2013 model, since its the second time it left me in the middle of the intersection, dash full of warnings like it was a chistmas tree. Last year I had a similar issue with Check hybrid system warning pop up at a stop. It proved to be the oil pump inside the transmission. This year, similar behavior plus check engine light and a service light. I had it for two months in the kia shop and they couldnt figure it out. The error code is P0A78 Drive motor A invertor performance.
They said it could be something in the transmission, so they changed the clutch pack disks and two bearings or something like that and still no go. They they said its the electric engine and also it could be the HPCU unit...but I cant afford to spend so much money on their guesses ...so I moved it to a hybrid service in the area.
The electrical engine seems to be good, but the inverter is not...so I started searching for a SH one...as new is almost 5000$ but it seems to be hard to find one that fits my car...as other regions have an additional plug that I dont have...
Any chance you might know somewhere i could get it from totaled cars?
 

·
Registered
Joined
·
1 Posts
Litterally just had mine replaced today. The dealer and Kia shared the cost of the part as it appears to have been the root issue since I bought my optima hybrid in 2011. Motor would cut out and not engage, started rolling backwards... there are olm resistentance tests to check the health of of the HPCU. Mine was buggered and never gave codes, most frustrating.

I've only driven it a couple times today so it's still relearning my driving habits, but I've already noticed my breaking is less jerky and same for when I start rolling, much smoother.
 
1 - 2 of 2 Posts
Top