Kia Optima Forums banner

41 - 60 of 86 Posts

·
Premium Member
2012 Kia Optima
Joined
·
1,684 Posts
Discussion Starter #42
Hey there

I just replaced my fog light bulbs and had a question. Once you align the bulbs into the 3 open tabs and turn did you hear a "click"? On the normal factory bulbs once I turned it I heard a click like it was locking it into place but with the aftermarket bulbs I did not hear a click. I don't think the bulb would fall out but not sure if I did something wrong since the factory bulb clicked when you turned it to lock it into place.

From the outside you can see the three tabs on the bulbs so I know when you go to pull on the bulb from the back it won't come out... it's just when you turn it it will obviously turn and you can pull it out.

Also the LED lights look much better on yours. I bought the same bulb but since I have a pair of OSRAM CBI 5k HID bulbs (factory HID) and the DRL lights, the fog lights looked out of place.

Thanks for putting this install together too, it helped me a lot!

oops didn't see your reply lol. It doesn't make a click sound, but you should feel a gently "lock" where it feels secure in the 3 prongs. You might hear a very gently dudded click? but i doubt it. If you gently pull on it and it doesn't move around you'll be okay.
As for the brightness... I'm running 4300K HID from Diode Dynamics 35W. While these are bright, i dont think they're as bright as the ones you're running? So that might make it seem like mine are brighter than your's
 

·
Registered
Joined
·
463 Posts
Thanks for the easy instructions . I did mine in the snow in about -8°c temps and it still only took me about 10 mins. I love easy painless installs :)
 

·
Registered
Joined
·
1,878 Posts
I bought the same bulb but since I have a pair of OSRAM CBI 5k HID bulbs (factory HID) and the DRL lights, the fog lights looked out of place.

Thanks for putting this install together too, it helped me a lot!
I have 5K TRS H11 HID Bulbs and honestly they almost match perfect with these Fog LEDs... A tad bit difference but really not noticeable if you didnt know one was LED and one was HID like I do... What looked out of place were the stock yellowish halogen bulbs with the LED Fogs... Now just to find some whiter High Beam Bulbs... I plan on upgrading to the 80W Fogs after Christmas tho, more money for David!
 

·
Your K5 Optima Vendor
2017 Tesla Model X
Joined
·
28,212 Posts
I have 5K TRS H11 HID Bulbs and honestly they almost match perfect with these Fog LEDs... A tad bit difference but really not noticeable if you didnt know one was LED and one was HID like I do... What looked out of place were the stock yellowish halogen bulbs with the LED Fogs... Now just to find some whiter High Beam Bulbs... I plan on upgrading to the 80W Fogs after Christmas tho, more money for David!
Awesome glad to hear this! Jared let me know when you're ready to upgrade. Don't forget the store credit you have. :)
 

·
Premium Member
2012 Kia Optima
Joined
·
1,684 Posts
Discussion Starter #46
Thanks for the easy instructions . I did mine in the snow in about -8°c temps and it still only took me about 10 mins. I love easy painless installs :)
that is some dedication to your car.... I need to replace mine since i upgraded but I'm waiting for warmer weather or waiting till i go visit my parents so i can do it in a warmer and not wet grounds lol
 

·
Premium Member
2012 Kia Optima
Joined
·
1,684 Posts
Discussion Starter #48
nope.... it's been snowing like crazy in NJ... I'll be doing that once I can touch the ground without freezing to death lol
 

·
Registered
Joined
·
1,878 Posts
I got my fasteners today & while they are not "identical" to the OEM fasteners they seem to work & were only $.33 each (shipped). I replaced the 1 I destroyed when putting my fod light bulbs in and I could not pull it back out by hand so it seems to be holding. Im gonna give it a couple days and check to make sure it is still in place... I might even replace a couple on the trunk liner and see how they hold up...

They even got here pretty quick from Hong Kong, I ordered them on 9/24/2013 & they came today...

Here is a pic of them compared to a factory fastener which is on the far right.
View attachment 50593

If anyone wants a link to them on ebay let me know and Ill msg it to you... I dont want to post it in the public before I complete my testing to ensure they will in fact work...
Just and update these clips I got have been working perfect, I even replaced a couple more OEM ones when I put the new 80W Fogs in a couple months ago & they are all still in there and holding the plastic covers just fine...
 

·
Your K5 Optima Vendor
2017 Tesla Model X
Joined
·
28,212 Posts
nope.... it's been snowing like crazy in NJ... I'll be doing that once I can touch the ground without freezing to death lol
I gotcha, make sure to post up some pics of the new ones once you get them installed. ;)

Thanks gmoney and K5 Dave!
You are very welcome!

Just and update these clips I got have been working perfect, I even replaced a couple more OEM ones when I put the new 80W Fogs in a couple months ago & they are all still in there and holding the plastic covers just fine...
Good to know they are holding up and are good quality like the OEM ones.
 

·
Registered
Joined
·
13 Posts
I just installed a pair of bulbs yesterday in -15 C & without lifting the car up. I've to agree the space for installation is very very tight and I did not want to pull down the plastic cover too much in-case causing any breakage. I spend like half an hour for each side due to I was not even able to see inside clearly even I lay on the ground.

Here is my question, After install the bulb into the housing, when plugging the plug (socket) back to the bulb, were you guys able to click BOTH tap securely? I seem able to 'click' one side only with my frozen fingers. Will that cause any failure by water intrusion.......etc? Thanks in advance!
 

·
Your K5 Optima Vendor
2017 Tesla Model X
Joined
·
28,212 Posts
I just installed a pair of bulbs yesterday in -15 C & without lifting the car up. I've to agree the space for installation is very very tight and I did not want to pull down the plastic cover too much in-case causing any breakage. I spend like half an hour for each side due to I was not even able to see inside clearly even I lay on the ground.

Here is my question, After install the bulb into the housing, when plugging the plug (socket) back to the bulb, were you guys able to click BOTH tap securely? I seem able to 'click' one side only with my frozen fingers. Will that cause any failure by water intrusion.......etc? Thanks in advance!
I too installed mine without lifting up the car. No you won't have any issues if only one tab clicked into place. Both clips should click into place, but it should not be an issue as long as they are plugged in nice and tight.
 

·
Registered
Joined
·
42 Posts
Just ordered mine, I chose the 80 watt because I want as much visibility as possible, but I should have asked first, which one matches the factory HID's?
 

·
Registered
Joined
·
42 Posts
This was the easiest install I ever did, and as long as you have a fat head screwdriver you dont have to worry about stripping the screws. Mines turned easily and everything came off smoothly. Took around 20 min with all the setting up and moving **** around. But the actual work does take like 2 min to do once the car is jacked up and all the screws are off lol

Definitely bright as ****, cant wait to drive at night
 

·
Premium Member
2012 Kia Optima
Joined
·
1,684 Posts
Discussion Starter #58
yup i just installed the new 80Watt, wanted to take some more pictures but my phone was dead and i dont own a camera =(
But i'm glad to see this DIY is helping out people
 

·
Registered
2012 KIA Optima
Joined
·
117 Posts
Got my new fogs quickly after I ordered them and installed them in 10 minutes after reading this post thank you
 
41 - 60 of 86 Posts
Top