Kia Optima Forums banner

81 - 89 of 89 Posts

·
Registered
2013 Optima Optima SXL
Joined
·
551 Posts
Import, very happy to see you are getting help
 

·
Registered
2012 Optima Kia
Joined
·
42 Posts
Well I think at this point I will need to get this done professionally. David you know anybody that would install the trs? Can't think of any places in Orange County
 

·
Registered
2015 KIA OPTIMA
Joined
·
193 Posts
Well I think at this point I will need to get this done professionally. David you know anybody that would install the trs? Can't think of any places in Orange County
Too bad your not in the central valley lol. I'm pretty good at installing these harnesses

Sent from my Nexus 5 using Tapatalk
 

·
Registered
2013 Optima SWP
Joined
·
425 Posts
I've got a set from TRS (5,500K 35W with H11b stock bulb, ordered the correct type of bulb from K5Optima) that I plan on installing this weekend but I have a few questions before I start. I've read through a bunch of posts on HIDs already so I feel fairly confident.

1. With the relay harness can I plug in the spade connectors on the passenger side or does it HAVE to be the driver's side?

I do believe you have to wire in the driver's side spade connectors because of the length of the wires coming from the relay. This was the biggest hurdle in the installation. Huge PITA.

2. Does the anti-flicker wire have to plug into the same side of the car as the spade connectors?

I wired it this way.


3. Just for my confirmation, does this anti-flicker wire plug into the relay harness wire labeled "OEM Input" for those that have used TRS HIDs?

Yes

4. Where is THE best place to connect the positive wire? If it's the fuse box do I have to make any modifications to the cover to accommodate the additional wire that runs out of the box?

I wired it to the fuse box and didn't have to make any modifications for it to fit. The cover snaps back in place.

Thank you.



Well I went ahead and installed them.

I'll answer my questions and possibly help anyone who's wanting to do this mod. Light output is much better and I like the color. Cut off is sloppy but expected. Occasionally I won't get one or the other light to turn on. I can fix it by turning the lights completely off and back on. May or may not have something to do with them turning on with the car. I'll have to see if switching them on after the car has started more often to see if this is a solution.
 

·
Registered
2013 Optima SWP
Joined
·
425 Posts
Someone, anyone!
 

·
Registered
2011 Kia Optima
Joined
·
23 Posts
I know I'm digging up an old thread but is there a trick that I'm missing for seating the Morimoto H11 bulbs? I can't get them to twist like the OEM halogen bulbs. I have the bumper off and the battery removed. I'm F'n beyond pissed that I can't complete the install right now

---------- Post added at 04:41 PM ---------- Previous post was at 11:01 AM ----------

I figured it out. I took the bracket off and seated them then put the bracket back in. Now I can't get both headlights to come on. They both work but only one at a time. I'm hoping its a ground and not the mopar harness.
 

·
Registered
Joined
·
3 Posts
So I just installed a HID kit on my 2013 optima and it’s just a plug and play kit. When I turn my key they come on but once I start the motor they go off. Why is that?
 

·
Your K5 Optima Vendor
2017 Tesla Model X
Joined
·
28,238 Posts
So I just installed a HID kit on my 2013 optima and it’s just a plug and play kit. When I turn my key they come on but once I start the motor they go off. Why is that?
Was it a cheaper priced HID kit? Where did you order it from? Many of the cheaper HID kits found online ie. eBay/Amazon are not designed to work with the electrical system on the Kia Optima, and therefore, will not function properly.
 
81 - 89 of 89 Posts
Top