Kia Optima Forums banner

1 - 14 of 14 Posts

·
Registered
2012 Kia Optima Ex-T
Joined
·
37 Posts
Discussion Starter #1
hey guys recently my check engine light came on and my car started running really funny, it has no power what so ever, its almost as if its running naturally aspirated like without the turbo.

anyways I ran the check engine light and it only threw one code, witch is the boost control sensor.

Now, I was wondering if anybody could point in the direction. of this sensor. I don't know were its located. A picture would be even better lol

thanks
 

·
Registered
2014 Kia Optima
Joined
·
92 Posts
If i'm not mistaken, that sensor is on the intake. You can't miss it. It's the only one on there. Give me a few and i'll post a picture of it.

Edit:

Not sure how much of a difference it would be since your vehicle is older, but it should look something like what's in the photo.
 

Attachments

·
Registered
2014 KIA Optima
Joined
·
1,663 Posts

·
Registered
Joined
·
164 Posts
.....you sir have a electric wastegate actuator out of range. Depending on your milage your dealer may fix it for free if not most dealre charge about $250 for this fix and the car must be left there overnight. If you are savvy enough search this forum for "wastegate adjustment" and there is a how to on doing it yourself.

---------- Post added at 11:41 AM ---------- Previous post was at 11:37 AM ----------

http://www.optimaforums.com/forum/22-optima-diy/8123-waste-gate-actuator-adjustment-turbo-charged-optima-power-loss-problem.html


here you go. I'm surprised it took two hours to get your answer.... activity on this forum has gone down by a crazy amount. if you frequent Facebook you might want to look for this group...."Korean automotive tuning association" there is lots of knowledgeable people in that group and if you need help you can get answers in minutes.
 

·
Registered
2012 Kia Optima Ex-T
Joined
·
37 Posts
Discussion Starter #6
thanks guys, the code is p2562. I'm trying to get it done myself because the dealers in my area are out about 2 weeks for service. and also because I don't want them saying anything about my aftermarket intake, nor do I feel like changing it.and the last 3 times i tokm ny car into the dealer i recieved very poor customer service.I'm pretty mechanichly inclined so I'm sure with this info I should be able to figure it out.I'm defiantly going to look into the wastegate just in case but i dont thinkthe code suggest anything to do with the wastegate. I already checked for vacuum and boost leaks as well
 

·
Your K5 Optima Vendor
2017 Tesla Model X
Joined
·
28,707 Posts
thanks guys, the code is p2562. I'm trying to get it done myself because the dealers in my area are out about 2 weeks for service. and also because I don't want them saying anything about my aftermarket intake, nor do I feel like changing it.and the last 3 times i tokm ny car into the dealer i recieved very poor customer service.I'm pretty mechanichly inclined so I'm sure with this info I should be able to figure it out.I'm defiantly going to look into the wastegate just in case but i dont thinkthe code suggest anything to do with the wastegate. I already checked for vacuum and boost leaks as well
Welcome, and that makes sense. Not sure if it is the Wastegate issue either, but if it turns out to be that, you can see what the techs would see when doing the TSB here:

Wastegate TSB - Kia Optima

Hope it helps.
 

·
Registered
2014 KIA Optima
Joined
·
1,663 Posts
thanks guys, the code is p2562. I'm trying to get it done myself because the dealers in my area are out about 2 weeks for service. and also because I don't want them saying anything about my aftermarket intake, nor do I feel like changing it.and the last 3 times i tokm ny car into the dealer i recieved very poor customer service.I'm pretty mechanichly inclined so I'm sure with this info I should be able to figure it out.I'm defiantly going to look into the wastegate just in case but i dont thinkthe code suggest anything to do with the wastegate. I already checked for vacuum and boost leaks as well
No problem.

We try to help when we can.

I looked up the code and it seems to be code that points to the waste gate as the issue.

However, the generic code also fingers other items like the boost sensor, inter-cooler ,etc.

I would try to the waste gate fix mentioned above and then go to the dealer if that does not solve the issue.

https://www.yourmechanic.com/article/p2562-obd-ii-trouble-code-turbocharger-boost-control-position-sensor-circuit-by-parker-hill
 

·
Registered
2013 Kia SX
Joined
·
505 Posts
Yeah that's your wastegate adjustment issue. I haven't done one in a long time now but relatively easy. It's recommended to do it on a stone cold engine though. If it did turn out to be that boost sensor on the intake as shown you would be throwing a p0106 i believe for manifold pressure. I've done one of those a few years ago.
 

·
Registered
2012 Kia Optima Ex-T
Joined
·
37 Posts
Discussion Starter #10
so I checked out the link above about the wastegate issue and I think that's what it is, before it would do it every so often and if I restarted the car it would be fine, but now that the check engine light is on the problem no longer goes away with an engine restart
 

·
Registered
SXL
Joined
·
18 Posts
So everyone I have a 2013 sx I've adjusted that wastegate rod about 8 or 9 times now, finally it didnt it again so I took it to the dealer they told me to replace it, so I left it overnight for them to put it, but on my way there I threw another code for the boost sensor crapping out, it's the sensor located on the intake side of the charge pipe to the throttle body. So guess I'm just saying my Sx is at 298362 miles and I'm finally replacing it. Lol
Love my SX.
Hopefully they get it right.
 

·
Registered
SXL
Joined
·
18 Posts
Yes got the engine replaced at 124603. Only the short block everyone here thinks you get a new motor , you only get the head and block so it's really not a new complete motor. Your turbo,intake, injectors etc are all from the original motor.
I oil change every 5000 miles , I tranny flush every 55000 miles I coolant flush every year. I brake flush every year I change my brake pads regardless every 3 to 4 months (lifetime warrenty free replacement)
Front end alignment every 6 months tires rotated every 4000 miles. Yes I maintain the **** out of her. But I will get 500000 I guarantee it.
And I'm buying the 2021 K5 GT Awd
 

·
Registered
SXL
Joined
·
18 Posts
Oh yeah oops so I got the new actuator installed, part cost 225 on HORNE kia web page and the boost sensor. They did an ok job. The boost is back I'm not sure what they set the voltage at bit I'm thinking its prob about 3.8 to 3.9 because that's were they constantly set it, well I'll tell you it's not enough. Its hesitant to open up. When I go and set it myself to 4.21 to 4.23 this thing becomes a beast !! So I'll let you know after I get back into it.
 
1 - 14 of 14 Posts
Top