Kia Optima Forums banner
1 - 7 of 7 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter · #1 ·
I have a 2011 Kia Optima. It had clunk in steering. Replaced steering coupler. After putting all back together the eps light was on and had no power steering. Was told had to take to Kia dealer to reset. They said they was unable to reset it so I have no idea what is wrong. Anyone have any knowledge on this issue?
 

·
Registered
Joined
·
4 Posts
Discussion Starter · #2 ·
I have a 2011 Kia Optima. It had clunk in steering. Replaced steering coupler. After putting all back together the eps light was on and had no power steering. Was told had to take to Kia dealer to reset. They said they was unable to reset it so I have no idea what is wrong. Anyone have any knowledge on this issue?
Traction control light is also on
 

·
Registered
2012 Black SX Prem. & Tech.
Joined
·
2,197 Posts
Sounds like there might have been an issue during re-assembly.

If you have the time and energy, maybe you can just repeat the procedure but look for any loose connections or problems that are out of the ordinary. Maybe the power motor is not all the way in, or somehow not connected properly?
 

·
Registered
Joined
·
69 Posts
There was a recall on that coupler. You should've just taken it to Kia and had them do it for free. Then if it had done that there, it would've been on them to fix for free as well.
 

·
Registered
Joined
·
4 Posts
Discussion Starter · #5 ·
There was a recall on that coupler. You should've just taken it to Kia and had them do it for free. Then if it had done that there, it would've been on them to fix for free as well.
I found that out after putting coupler in.
 

·
Registered
Joined
·
4 Posts
Discussion Starter · #6 ·
Was thinking of buying new module but don’t know if that would have to be reprogrammed after installing?
 
1 - 7 of 7 Posts
Top