Kia Optima Forums banner

461 - 480 of 520 Posts

·
Registered
Joined
·
292 Posts
When you take your car into a dealership for service, say an oil change, do they check your software/TSB's? Or do they only do this if there are problems and they are troubleshooting?

Bought my 2012 SX used in December 2012 with 9,000 miles. Thing has been perfect up until today, about 22,000 or so miles, I didn't have any power, assuming it's the wastegate issue because I restarted the car and it worked fine. It was 75 degrees this morning, so not a cold weather issue.. was going along fine until I was going uphill and noticed my foot on the accelerator like it always is wasn't pushing the car uphill.. had to give it more gas, the RPMs reved with little response in power... parked in a parking lot for fear of not being able to start back up if I did it at a stoplight, restarted the car and everything was fine. Thoughts?
 

·
Registered
Joined
·
454 Posts
WGA is the wastegate actuator. What you described (especially with your mileage) is what is more than likely a variance in the voltage of the wastegate actuator which causes the car to temporarily go into limp mode (no power).
 

·
Registered
Joined
·
75 Posts
WGA is the wastegate actuator. What you described (especially with your mileage) is what is more than likely a variance in the voltage of the wastegate actuator which causes the car to temporarily go into limp mode (no power).
Do they know why this is happening and is there any preventive maintenance that can be done? I'm nervous that I'm going to have to deal with this or the spark plug cylinder 2 issue in the future. I plan on modding my new '13 SX with headers, intake and exhaust... don't want to get any grief or my warranty voided for having aftermarket parts on my car.
 

·
Registered
Joined
·
292 Posts
I'm assuming CEL means check engine light... No I haven't had that come on yet, should I be expecting the WGA issue to get progressively worse until I DO get a CEL or could this one time have been a random occurrence?

Also if it doesn't happen until next scheduled service, would they take my word for the issue and check into it or is this something they need the CEL to be able to read a code for?

Sent from AutoGuide.com App
 

·
Registered
Joined
·
4 Posts
So i had this issue leaving work on Friday. It was fine at lunch, then when I left for the day, I felt like I was driving a golf cart. No amount of restarting the car or unhooking the battery would fix it. I set up an appointment to take it in. Being curious I decided to look around for anything obvious. Popped the hook and checked out the wastegate rod and the **** thing is just hanging there! It broke off from the actuator! I unbolted the actuator (took about 2 minutes) and pulled it out. The threaded part snapped off the actuator, so it will need a new actuator. The only problem is I am at 41,500 miles, so Im sure they will tell me I am SOL. I did have it in there about 6 months ago for a buzzing from the wastegate area, but they couldn't duplicate it, of course. I am going to try and see if they will do anything for me. If not, I guess I will order the part and replace it myself. Here are a couple pictures...



 

·
Registered
Joined
·
454 Posts
I'm assuming CEL means check engine light... No I haven't had that come on yet, should I be expecting the WGA issue to get progressively worse until I DO get a CEL or could this one time have been a random occurrence?

Also if it doesn't happen until next scheduled service, would they take my word for the issue and check into it or is this something they need the CEL to be able to read a code for?

Sent from AutoGuide.com App

Yes, CEL means check engine light. If the voltage went back to a "acceptable range" the WGA will open and close normally, thus no CEL. However there is a high likelihood it will happen again, and if it's for an extended period of time (20 miles or so), the CEL will come on. The dealer states they prefer that the CEL is on during the time of fix, however I am sure they can use an OBDII scanner to look up previous CEL's in the past.

There is tons of "how to's" on here to fix it yourself. It's very straight forward and easy. I even made a video on YouTube walking you through the process.
 

·
Registered
Joined
·
454 Posts
So i had this issue leaving work on Friday. It was fine at lunch, then when I left for the day, I felt like I was driving a golf cart. No amount of restarting the car or unhooking the battery would fix it. I set up an appointment to take it in. Being curious I decided to look around for anything obvious. Popped the hook and checked out the wastegate rod and the **** thing is just hanging there! It broke off from the actuator! I unbolted the actuator (took about 2 minutes) and pulled it out. The threaded part snapped off the actuator, so it will need a new actuator. The only problem is I am at 41,500 miles, so Im sure they will tell me I am SOL. I did have it in there about 6 months ago for a buzzing from the wastegate area, but they couldn't duplicate it, of course. I am going to try and see if they will do anything for me. If not, I guess I will order the part and replace it myself. Here are a couple pictures...

EKKKKK! No bueno bro. Knowing how dealerships work and how they'll use anything to get out of fulfilling warranty work, I highly doubt they can (or want to) make a correlation between the WGA rod rattle and the fact the bolt broke. Keep us posted.
 

·
Registered
Joined
·
292 Posts
Yes, CEL means check engine light. If the voltage went back to a "acceptable range" the WGA will open and close normally, thus no CEL. However there is a high likelihood it will happen again, and if it's for an extended period of time (20 miles or so), the CEL will come on. The dealer states they prefer that the CEL is on during the time of fix, however I am sure they can use an OBDII scanner to look up previous CEL's in the past.

There is tons of "how to's" on here to fix it yourself. It's very straight forward and easy. I even made a video on YouTube walking you through the process.
Could you link me to it please?


Sent from AutoGuide.com App
 

·
Registered
Joined
·
4 Posts
Well I took it in today. Went better than expected. I swear the bumper to bumper was only 3/36, but he told me I was good for 5/60. They ordered a new actuator, should be here in a couple days. Man this thing is slow without boost!
 

·
Registered
Joined
·
17 Posts
Well I started having the same issue as everyone else with the lack of power. Sat. I tried to power off and then back on and still no power and the odd shifting. My problem is that I am at 61,000 miles. 1,000 over warranty. Does any one know how much these fixes are going to cost me since I have no warranty??
 

·
Registered
2011 Kia Optima
Joined
·
1,637 Posts
Well I started having the same issue as everyone else with the lack of power. Sat. I tried to power off and then back on and still no power and the odd shifting. My problem is that I am at 61,000 miles. 1,000 over warranty. Does any one know how much these fixes are going to cost me since I have no warranty??
being that there is a known TSB on this, should be FOC (free of charge)
 

·
Registered
Joined
·
116 Posts
I hope your right I know with Hyundai it's only free of charge while the warranty is in effect...having said that isn't the waste gate part of the engine which has a 10 year 100,000 mile! warranty.
They way it was explained to me, and I think its BS, but if there is a service bulletin it's the owners responsibility to find out about it and have it corrected UNDER warranty if you do nothing or the problem doesn't occur until after the warranty expires TOUGH.
That only applies to service bulletins NOT recalls of course.
Take it in and see what they say hopefully you have a good relationship with the dealer and have had all your servicing done there as per the maintenance schedule or they will try and stiff you on that too.
Good luck let us know what happens
being that there is a known TSB on this, should be FOC (free of charge)
 

·
Registered
Joined
·
17 Posts
UPDATE: Couple things. From what I understand if you buy your car new, you get the 10 year 100,000 mile warranty. If you buy it used like I did at non Kia dealership it changes to a 5yr 60,000 mile warranty. I just didn't mention anything about the warranty. I just told them the problems I have been having and that I new about the TSB110 and some of the other fixes that I read on here. They did the update with the ENG099 and everything works better than it did before and was all free.
 

·
Registered
Joined
·
224 Posts
I think I'm having this problem as well. Since this morning I got in the car warmed it up a bit and started driving I noticed the car felt like it was loosing power, I also kept hearing the bov go off when I wasn't even going hard on the gas, just driving normal. Now I get in the car from it being parked all day start the car and the check engine light turns on. I drive off and its driving perfectly fine like the day I got it, and I hear the bov when I want to hear it not all the time like in the morning.


Sent from AutoGuide.com App
 

·
Registered
Joined
·
224 Posts
I think I'm having this problem as well. Since this morning I got in the car warmed it up a bit and started driving I noticed the car felt like it was loosing power, I also kept hearing the bov go off when I wasn't even going hard on the gas, just driving normal. Now I get in the car from it being parked all day start the car and the check engine light turns on. I drive off and its driving perfectly fine like the day I got it, and I hear the bov when I want to hear it not all the time like in the morning.


Sent from AutoGuide.com App
Update!! This morning I get in the car check engine light is gone, and the cars is driving normal!!


Sent from AutoGuide.com App
 

·
Premium Member
2011
Joined
·
4,420 Posts
Well it finally got me after having the car for about 2 yrs now :angry:, and it happened when I got off work to a cold start. Will be bringing it to the dealer in a day or two and hopefully they don't give me a hard time about my CAI Injen which it shouldn't be an issue. But then again you'll never know what these freaking dealers will say lol. Looks like TSB 110 is a good fix so I'll mention that to them.
 
461 - 480 of 520 Posts
Top