Kia Optima Forums banner
1 - 17 of 17 Posts

·
Registered
Joined
·
10 Posts
Discussion Starter · #1 ·
I have a 2015 kia optima EX 2.4
Recently been dealing with an intermittent code that has turned off twice and came back on. I have researched online and every solution points towards a sensor that is connected right onto the catalytic converter itself. I jacked up my car and went under and found no sensor or even spot to connect one. Kind of stumped here anyone else deal with this issue before? The message from the computer scan says fuel bank 1 too lean. And every solution online states its the fuel bank 1 sensor 2 but I cannot find it! Anything helps.
 

·
Registered
Joined
·
10 Posts
Discussion Starter · #3 ·
I could not find one. Unless it is after the converter itself? I will have to give it another look then. Which would be odd since I have replaced o2 sensors before for other check engine light error codes and it matched correctly everytime. Just this one I cannot find and it's driving me nuts. However it does not affect the way the car drives.
 

·
Registered
2011 Kia Optima
Joined
·
4,332 Posts
Not familiar with the 2.4 as to the particulars of the O2 sensor, but look up on top of the exhaust manifold for the upstream, then naturally the one lower
down would be the downstream.
 

·
Registered
2013 Kia Optima
Joined
·
491 Posts
I have a 2015 kia optima EX 2.4
Recently been dealing with an intermittent code that has turned off twice and came back on. I have researched online and every solution points towards a sensor that is connected right onto the catalytic converter itself. I jacked up my car and went under and found no sensor or even spot to connect one. Kind of stumped here anyone else deal with this issue before? The message from the computer scan says fuel bank 1 too lean. And every solution online states its the fuel bank 1 sensor 2 but I cannot find it! Anything helps.
Yes that code is for the bank 1 sensor 2/downstream O2 sensor/O2 sensor after cat. if you don't see it, you're not looking good enough. mine has been doing the same thing and just ignore it as long as it keeps going away. you're not going to fix it by replacing just the sensor. usually it's the cat starting to go bad.
 

·
Registered
Joined
·
10 Posts
Discussion Starter · #6 ·
Yes that code is for the bank 1 sensor 2/downstream O2 sensor/O2 sensor after cat. if you don't see it, you're not looking good enough. mine has been doing the same thing and just ignore it as long as it keeps going away. you're not going to fix it by replacing just the sensor. usually it's the cat starting to go bad.
You have the 2.4 four cylinder EX?
 

·
Registered
Joined
·
10 Posts
Discussion Starter · #8 ·
One thing I will note is that I figured the location. However I changed this sensor a year ago. Car is at 103k miles perhaps old spark plugs could be the cause of such a low life span of these sensors?
 

·
Registered
2011 Kia Optima
Joined
·
4,332 Posts
They can become contaminated, however, I've never experienced that phenomenon as the problem was the cat.
Here's a list you can go through.
Common causes of the P0420 code?

  • Damaged muffler or leaks in the muffler.
  • Damaged exhaust manifold or leaks in the exhaust manifold.
  • Damaged exhaust pipe or exhaust pipe leaks.
  • A misfire in the engine.
  • Oil contamination in catalytic converter.
  • Faulty catalytic converter (most common).
  • Faulty engine coolant temperature sensor.
  • Faulty front oxygen sensor.
  • Faulty rear oxygen sensor.
  • Damaged oxygen sensor wiring.
  • Oxygen sensor wiring that is not properly connected.
  • Damaged oxygen sensor connectors
  • A leaking fuel injector.
  • High fuel pressure.
  • Use of the wrong kind of fuel (using leaded fuel instead of unleaded fuel)
 

·
Registered
Joined
·
10 Posts
Discussion Starter · #10 ·
They can become contaminated, however, I've never experienced that phenomenon as the problem was the cat.
Here's a list you can go through.
Common causes of the P0420 code?

  • Damaged muffler or leaks in the muffler.
  • Damaged exhaust manifold or leaks in the exhaust manifold.
  • Damaged exhaust pipe or exhaust pipe leaks.
  • A misfire in the engine.
  • Oil contamination in catalytic converter.
  • Faulty catalytic converter (most common).
  • Faulty engine coolant temperature sensor.
  • Faulty front oxygen sensor.
  • Faulty rear oxygen sensor.
  • Damaged oxygen sensor wiring.
  • Oxygen sensor wiring that is not properly connected.
  • Damaged oxygen sensor connectors
  • A leaking fuel injector.
  • High fuel pressure.
  • Use of the wrong kind of fuel (using leaded fuel instead of unleaded fuel)
How do you know if the cat converter is bad?
 

·
Registered
Joined
·
10 Posts
Discussion Starter · #12 ·
Normally, if the downstream sensor is good I'd assume the converter is a fault.
Never had a converter crumble/clog, so never tried this:

As I stated before, if continuing problems, just use the extender or non foulers, and if the converter is clogged there are other avenues to correct cheaply.
Where can you purchase these. Replaced the sensor and cel came right back
 

·
Registered
Joined
·
10 Posts
Discussion Starter · #13 ·
Normally, if the downstream sensor is good I'd assume the converter is a fault.
Never had a converter crumble/clog, so never tried this:

As I stated before, if continuing problems, just use the extender or non foulers, and if the converter is clogged there are other avenues to correct cheaply.
Also do you think if since I haven't ever changed the spark plugs this could cause the issue?
 

·
Registered
Joined
·
10 Posts
Discussion Starter · #17 ·
They can become contaminated, however, I've never experienced that phenomenon as the problem was the cat.
Here's a list you can go through.
Common causes of the P0420 code?

  • Damaged muffler or leaks in the muffler.
  • Damaged exhaust manifold or leaks in the exhaust manifold.
  • Damaged exhaust pipe or exhaust pipe leaks.
  • A misfire in the engine.
  • Oil contamination in catalytic converter.
  • Faulty catalytic converter (most common).
  • Faulty engine coolant temperature sensor.
  • Faulty front oxygen sensor.
  • Faulty rear oxygen sensor.
  • Damaged oxygen sensor wiring.
  • Oxygen sensor wiring that is not properly connected.
  • Damaged oxygen sensor connectors
  • A leaking fuel injector.
  • High fuel pressure.
  • Use of the wrong kind of fuel (using leaded fuel instead of unleaded fuel)
Check engline light came back on. Took it to a mechanic he says the cat needs replaced. Is there any way to tell if it is the manifold or the one under the car? He mentioned something about welding so I am assuming it is the bottom one?
 
1 - 17 of 17 Posts
Top