Kia Optima Forums banner
1 - 3 of 3 Posts

·
Registered
2017 SX-Turbo
Joined
·
11 Posts
Discussion Starter · #1 · (Edited)
Started car today. Noticed a quickly dissipating cloud behind me. Ok, it rained/snowed yesterday. After allowing vehicle to run for 3-4min l begin to back up my very steep 100ft driveway, all the while with that cloud of what appeared to be water vapor. I get to the top put it in D and the check engine light comes on.
I just bought this car on February 5. I had previously noticed several times after driving that when I stopped there was a cooling system smell.
I stop, get out with car running and could see and feel with my hand a very hot moist vapor from the left exhaust but not from the right side. I immediately park the car. Radiator overflow tank is down to "low" level.
I start the car again in 5min and no check engine light.
What's going on here?
  • 37k miles, Certified Kia w/Platinum warranty.
  • Thanks.
 

·
Registered
2011 Kia Optima
Joined
·
3,604 Posts
Have the code read free at parts store/garage, and as their is only one pipe from the converter to "Y" pipe connecting the mufflers, just one side can receive more exhaust than the other.

As far as coolant on low, that in itself is not an indication of loosing coolant unless you know it was on full recently. Having said that, if in fact the coolant has be lost, get a pressure tester put on the system, but that will only show if coolant is leaking, but one would need to see if leaking externally or pressure drops and no coolant noticed, internally. Check oil to see if any water, could be milky, remove radiator cap when cold, start engine and check for bubbles while looking into radiator.

Any vibration when first started? At times with coolant leaking into a cylinder, especially when engine off after a drive, a cylinder will miss as the water/gasoline in that cylinder won't ignite, but once running and water purged from that cylinder, the car will smooth out and run properly.

At least you're covered with a warranty.
 

·
Registered
2017 SX-Turbo
Joined
·
11 Posts
Discussion Starter · #3 ·
It was ok. We had snow and rain. Car was in carport and snow/rain was directed at the tailpipes. It was parked for four days and was just blowing out the moisture.
 
1 - 3 of 3 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top