Kia Optima Forums banner
1 - 6 of 6 Posts

· Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
2012 Optima Hybrid (120k)
Just bought this used and use it for rideshare and I LOVE it, however, after 2 weeks, the Check Engine Light (CEL) and the Service Maintenance Light (SML) came on together.

Took to AutoZone to scan and their scanner saw the SML but not the CEL. They reset it and both turned off.

Same lights came on and same result. Got my oil changed and they reset the lights as well. Lights came on after a day. The Grease Monkey scanner read the same thing…no CEL reading but yes on the SML.

Is there a was to clear the light manually? I can reset the mileage interval but haven’t found a way to clear the service light. Even hard rebooting by disconnecting the battery does not clear the lights.

Advice? Thanks in advance.
 

· Registered
Joined
·
475 Posts
Yes - use a device like this for example: https://www.amazon.com/Autel-AutoLi...automotive&sprefix=odb2+reader,aps,172&sr=1-6

Or one that uses your phone like this (for android but there are IOs versions): https://www.amazon.com/BAFX-Product...automotive&sprefix=odb2+reader,aps,172&sr=1-5

Or if you want lots more abilities/information besides CEL resets use a phone app like Torque Pro ($5) and an odb2 blue tooth connector like this: https://www.amazon.com/Kitbest-Blue...otive&sprefix=odb2+reader,aps,172&sr=1-7&th=1

Luck.
 

· Registered
Joined
·
2 Posts
Yes - use a device like this for example: https://www.amazon.com/Autel-AutoLi...automotive&sprefix=odb2+reader,aps,172&sr=1-6

Or one that uses your phone like this (for android but there are IOs versions): https://www.amazon.com/BAFX-Product...automotive&sprefix=odb2+reader,aps,172&sr=1-5

Or if you want lots more abilities/information besides CEL resets use a phone app like Torque Pro ($5) and an odb2 blue tooth connector like this: https://www.amazon.com/Kitbest-Blue...otive&sprefix=odb2+reader,aps,172&sr=1-7&th=1

Luck.
 

· Registered
2018 Optima EX, 2019 Stinger GT2 AWD
Joined
·
111 Posts
2012 Optima Hybrid (120k)
Just bought this used and use it for rideshare and I LOVE it, however, after 2 weeks, the Check Engine Light (CEL) and the Service Maintenance Light (SML) came on together.

Took to AutoZone to scan and their scanner saw the SML but not the CEL. They reset it and both turned off.

Same lights came on and same result. Got my oil changed and they reset the lights as well. Lights came on after a day. The Grease Monkey scanner read the same thing…no CEL reading but yes on the SML.

Is there a was to clear the light manually? I can reset the mileage interval but haven’t found a way to clear the service light. Even hard rebooting by disconnecting the battery does not clear the lights.

Advice? Thanks in advance.
If the lights keep coming back on after reset, then there is an issue that needs attention. Just clearing the indicators doesn't fix the underlying issue.
 

· Registered
Joined
·
70 Posts
To reset check engine light with no scan tool you pull both efi fuses for one min. it will clear all codes and reset your timing and idle speed back to stock and give your car more power for a while you will note idle speed will be slower till it relearn idle speed again about 5 start ups will do it.
 
1 - 6 of 6 Posts
Top