Kia Optima Forums banner
1 - 9 of 9 Posts

· Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
Hi there,
Kia Optima Phev 2018. A few days ago when I turned on the vehicle the Harmon Kardon sound system did not play any sounds what so ever. The Kia dealer in Denmark has spent two hours trying to diagnose the problem, but no luck so far. Everything on the multifunction display is working, Apple CarPlay is working, the system has had a full software update. Still no audio sound to be heard.
The Kia dealer has never had this issue before and the don’t know how to fix it. Has anyone in here had something Iike this before and do you have a fix for it?
 

· Registered
2013 Kia Optima
Joined
·
587 Posts
Hi there,
Kia Optima Phev 2018. A few days ago when I turned on the vehicle the Harmon Kardon sound system did not play any sounds what so ever. The Kia dealer in Denmark has spent two hours trying to diagnose the problem, but no luck so far. Everything on the multifunction display is working, Apple CarPlay is working, the system has had a full software update. Still no audio sound to be heard.
The Kia dealer has never had this issue before and the don’t know how to fix it. Has anyone in here had something Iike this before and do you have a fix for it?
Could try reseting the radio by pulling its fuse for several seconds while its on and putting it back in or it could be a blown AMP fuse since the only problem is that there is no sound.
 

· Registered
2016 Kia Optima SXL
Joined
·
741 Posts
Could try -- reseting the radio -- by pulling its fuse for several seconds while its on and putting it back in or it could be a blown AMP fuse since the only problem is that there is no sound.
For the amateurs, you mean the 15A Multi-Media Fuse in Inside Fuse Panel by Left Knee (column 6 in my '16) ?
FUSE PULLER in Engine Fuse Box.....
Hard to imagine the dealer didn't, BUT fingers crossed No...
 

· Registered
Joined
·
2 Posts
I have a 2011 deficiency and all of the unexpected I have no sound from the xm satellite radio, the customary radio, or Bluetooth . I haven't yet attempted to check whether route voice works or not i used to use Kodi & nox . Quiet button isn't on and I have turned the framework on and off. Anybody realize what is causing this?
 

· Registered
Joined
·
279 Posts
all I know is when they started to make the stereos from the dealerships without a fuse as part of the unit, weird electrical things started to happen! if your unit goes out, replace with an aftermarket unit the good ones still have a fuse in the back of them.
 

· Registered
2013 Kia Optima
Joined
·
587 Posts
all I know is when they started to make the stereos from the dealerships without a fuse as part of the unit, weird electrical things started to happen! if your unit goes out, replace with an aftermarket unit the good ones still have a fuse in the back of them.
I don't believe for one second that there is no fuse at all for any radio in any vehicle. if you replace a battery the wrong way that is on you. always pull positive off first when disconnecting and always put on ground first when connecting. this is also true when installing electronics. the worst thing you can do to electronics is have them searching for a ground while getting voltage.
 

· Registered
Joined
·
279 Posts
I know how to change a battery! been doing it for over 40 years. factory radios are made cheap and do not have fuses any longer. Ask any stereo installer if factory stereos have an internal fuse in the head unit.
 

· Registered
2018 Optima EX, 2019 Stinger GT2 AWD
Joined
·
111 Posts
Fuses and circuit breakers in general are there to protect the wiring from burring up causing a fire. This is true in homes as well as cars. That is why the fuses/circuit breakers are located near the main source of power, with wires branching out from there. If there is a short along the wire or in the device it feeds, then the fue blows or breaker trips, protecting the wiring.
Having a fuse at the device is really not necessary.
 
1 - 9 of 9 Posts
Top