Kia Optima Forums banner

1 - 20 of 71 Posts

·
Registered
Joined
·
44 Posts
Discussion Starter #1
I bought a Tesla style android unit from China (PX6, Android 9). My car is a 2013 model year and has automatic air conditioning, a navigator, Infinity audio and a reversing camera.

When the unit arrived, it came with a wiring harness with no canbus decors. I installed the unit and found that there is no sound at all. The steering wheel functions work. I contacted the seller and they promised to send the canbus decoders to the unit.

A new wiring harness arrived with canbus decoders. I installed them in the unit, but the situation was the same, there was no sound at all. A new feature was that the steering wheel functions no longer worked.

I contacted the vendor and they made a video call to check the connections and the canbus protocol was changed from the unit but there was no effect.

The seller promised to send new canbus decoders, and now I look forward to their arrival.

Many have installed a similar unit in their car as I have, and everything works. Could any of you tell me which canbus decoders you have in use? Does the other have to be an SPDIF canbus decoder for the sounds to work?
 

Attachments

·
Registered
Joined
·
44 Posts
Discussion Starter #3
The seller said the original camera could not be used on the android unit because the original camera was not designed for a larger screen. There are several options for camera settings in the unit menus, but I haven’t tried them. I bought a new camera and installed it. The camera receives its power from the reversing lights. I can take a picture if you want.

I also bought new TPMS sensors that communicate with the unit.

Here is a link to the unit I bought: US $576.23 16% OFF|Tesla style Android 9.0 Car GPS Navigation car No DVD Player For KIA Optima/KIA K5 2010 13 car stereo headunit Multimedia player|auto multimedia|android cardvd car player - AliExpress

New canbus decoders are on the way. Arrive according to the seller within 6-9 days. Communication with the seller is good and they respond quickly to questions.
 

·
Registered
2012 Black SX Prem. & Tech.
Joined
·
1,829 Posts
I'm interested in how long it takes to begin viewing the backup camera, from when you start the car to when you can view the camera. Could you take a viewo of that, like sit in the car, turn on, and view backup camera feed?
 

·
Registered
Joined
·
44 Posts
Discussion Starter #5
I can take a video when I get the unit to work. I am looking for new canbus decoders.

In the meantime, I have installed back to the original unit.

It would be really great if someone would take a picture of the canbus decoders or the picture of the unit settings where the protocol is selected.
 

·
Registered
Joined
·
44 Posts
Discussion Starter #6
Now the system works. My car has an original amplifier. No changes needed to be made.

I replaced the reversing camera. I can take a video of how fast the unit turns on the camera.

At first, I had a problem that there was no sound at all. The fault was that Can Hi and Can Lo were in the wrong place on the connector. I have photos before and after the change.
 

·
Registered
2012 Black SX Prem. & Tech.
Joined
·
1,829 Posts
Oh awesome, thanks so much for doing the groundwork on this! I am eager to see your video...
 

·
Registered
Joined
·
44 Posts
Discussion Starter #8

Here is the video I promised. I will make a better video soon. The sound quality is amazing.
 

·
Registered
2012 Black SX Prem. & Tech.
Joined
·
1,829 Posts
Wait, I counted three seconds between you pressing the start button and the tablet screen turning on.

Is there some way the tablet is maintaining power when the car is off? I don't understand how a tablet can boot up that quickly from a power-off state? I thought you had to wait for the tablet to boot up for a while, longer than shown in the video?.
 

·
Registered
2012 Black SX Prem. & Tech.
Joined
·
1,829 Posts
And also, how would I obtain the proper canbus decoder that you used, and how to fix the error between the canbus hi and canbus low?
 

·
Registered
Joined
·
44 Posts
Discussion Starter #12
If I understand correctly, the SPDIF signal to transmit the audio signal. The Canbus signal adjusts the volume. So both need to work for the amplifier to produce sound.

First measure the SPDIF signal from the amplifier. I had the original unit output 1.7 volts. The Android unit gave a result of 1.64 volts, so it can be concluded from the measurement that the SPDIF signal is working. I measured the SPDIF signal against the ground.
 

Attachments

·
Registered
Joined
·
44 Posts
Discussion Starter #15
Overall, the connector on the Android unit had the following wires in the wrong place:

-Canbus Hi
-Canbus Lo
-Steering key
-Illumination
 

·
Registered
2012 Black SX Prem. & Tech.
Joined
·
1,829 Posts
If you have a similar connector in your car as in my car, check the locations of the Canbus wires on both connectors. The picture shows the way my connectors had the Canbus wires in the wrong place.
So to fix, in the picture, you would change the two green wires coming out of the black connector, and move each one over one space so that the green wires line up with the brown wires?
 

·
Registered
Joined
·
44 Posts
Discussion Starter #18
Yes. I did just that. From the inside of the connector, when you press with thin pliers, you get the pin to come out of the connector and thus you can change the position of the pin in the connector without having to cut the wire or solder.
 

Attachments

·
Registered
2013 Kia Optima
Joined
·
489 Posts
How did you get the controls to glow like that in post #9?

I have that same unit, but I have a 2013 LX, so no canbus.
 
1 - 20 of 71 Posts
Top