Kia Optima Forums banner
1 - 5 of 5 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
Hello all,

2016 Optima LX FE here. I can’t get the TPMS light to stay off. After starting the car, the light flashes, then stays on. I have continuously adjusted the tire pressure, setting all 4 tires at 34 PSI. If the light comes on while driving, I stop and check the pressures; they’re usually 38-39, which I think is normal since the tires are hot at that point. Any suggestions will be great.
 

·
Registered
2013 Kia Optima
Joined
·
521 Posts
Hello all,

2016 Optima LX FE here. I can’t get the TPMS light to stay off. After starting the car, the light flashes, then stays on. I have continuously adjusted the tire pressure, setting all 4 tires at 34 PSI. If the light comes on while driving, I stop and check the pressures; they’re usually 38-39, which I think is normal since the tires are hot at that point. Any suggestions will be great.
It's not rare for the batteries inside the TPMS sensors to only last 5 years. May need to replace all 4 TPMS sensors.
 

·
Registered
2013 Kia Optima
Joined
·
521 Posts
I might go ahead and have them all replaced. I used a scan tool earlier and I had codes for all 4 sensors that said something like, radio frequency channel failure.
Think it's pretty rare to have all 4 go bad at the same time though so there may be something wrong with the TPMS receiver module or the programming. If it was me i would still change the sensors and go from there.
 
1 - 5 of 5 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top