Kia Optima Forums banner

1 - 2 of 2 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
This is the radio unit my EX 2015 Optima has (image from google): 913F3856-0785-485C-A0DC-2F6DA5E0E3C0.jpeg
Normally I have my iPhone connected through Bluetooth (but not USB) and everything works fine, I use it for spotify all the time. When I connect my phone with a lightning cable, it does the usual "reading media" and initial connection stuff, then says no media found, and switches to the radio. I start playing spotify (no audio coming from the phone, it thinks its playing through the car) and then hit the Media button on the Kia. Then it hangs on a "Connecting to Pandora" screen until it finds out my phone doesn't have Pandora, and switches back to the radio. The only way around this that I've found is to download the Pandora app on my phone, start playing music through it (which works), THEN switch to spotify and play music. This is a pretty gimmicky method, and even then the music player in the Kia doesn't properly reflect what I'm playing on Spotify (it thinks I'm still playing a song on Pandora).

Obviously I don't want to do all that every time I connect my phone to USB, so I just disconnect it and use bluetooth for music, and make sure my phone is well charged before any car ride. The problem is just that if I ever do need to connect my phone through USB, I have no easy way of playing spotify.

One strange thing to note is the first EVER time I connected my phone through USB a couple months back this never happened. It started to auto play Apple Music (the U2 album preinstalled) and I just switched to Spotify and the car media player showed the spotify song information as it should. I have since deleted the U2 songs from my Music library, so I wonder if Apple Music is the only music player the car picks up through USB - I guess I'll have to test later. Anyways, I'd love to hear if anyone has any solutions to this, perhaps some way to disable Pandora in the UVO system? I've already hit the paper clip reset button as well as factory reset the UVO system to no avail.
 

·
Registered
2013 Kia Optima
Joined
·
129 Posts
This is the radio unit my EX 2015 Optima has (image from google): View attachment 250093
Normally I have my iPhone connected through Bluetooth (but not USB) and everything works fine, I use it for spotify all the time. When I connect my phone with a lightning cable, it does the usual "reading media" and initial connection stuff, then says no media found, and switches to the radio. I start playing spotify (no audio coming from the phone, it thinks its playing through the car) and then hit the Media button on the Kia. Then it hangs on a "Connecting to Pandora" screen until it finds out my phone doesn't have Pandora, and switches back to the radio. The only way around this that I've found is to download the Pandora app on my phone, start playing music through it (which works), THEN switch to spotify and play music. This is a pretty gimmicky method, and even then the music player in the Kia doesn't properly reflect what I'm playing on Spotify (it thinks I'm still playing a song on Pandora).

Obviously I don't want to do all that every time I connect my phone to USB, so I just disconnect it and use bluetooth for music, and make sure my phone is well charged before any car ride. The problem is just that if I ever do need to connect my phone through USB, I have no easy way of playing spotify.

One strange thing to note is the first EVER time I connected my phone through USB a couple months back this never happened. It started to auto play Apple Music (the U2 album preinstalled) and I just switched to Spotify and the car media player showed the spotify song information as it should. I have since deleted the U2 songs from my Music library, so I wonder if Apple Music is the only music player the car picks up through USB - I guess I'll have to test later. Anyways, I'd love to hear if anyone has any solutions to this, perhaps some way to disable Pandora in the UVO system? I've already hit the paper clip reset button as well as factory reset the UVO system to no avail.
I have the same unit and i never charge my iphone with the usb because it always did weird things. i connect for music with bluetooth and charge with a cig plug with double usb port to charge me and someone else's phone.
 
1 - 2 of 2 Posts
Top