Kia Optima Forums banner

1 - 10 of 10 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter #1
I have a 2015 Kia Optima LX and my car will not start. Yesterday while driving I was hearing a clicking noise as I was pressing the gas pedal. I was slowly losing RPM and next thing you know my car completely shut off. Everything electrical in the car will turn on but my car will not start. Does anybody have an idea what the issue can be?
 

·
Your K5 Optima Vendor
2017 Tesla Model X
Joined
·
28,535 Posts
Welcome to the Optima Forums.

Sorry to hear about the issue you'r having o your 2015 Optima LX.

The very 1st thing I would check is the 12v battery, as it most likely needs to be replaced.

Hope that helps and fixes the issue you're having.

-David
K5 Optima Store
 

·
Registered
2011 Kia Optima
Joined
·
2,103 Posts
Did you notice whether the CEL came on before the engine died?
If access to a code reader check for stored codes.
Turn lights on and hit the key to start and see if lights go dim/out?
If bright and only dims slightly, not the battery.
 

·
Registered
Joined
·
5 Posts
Discussion Starter #4
as doin as it shut off on me the CEL came on, the oil lamp and the battery light came on
 

·
Registered
2015 Kia Optima
Joined
·
170 Posts
Possible engine failure?
 

·
Super Moderator
2012 Kia Optima
Joined
·
3,469 Posts
possible engine failure or perhaps the alternator? If the engine, you def should have codes all over the place. Good luck
 

·
Registered
Joined
·
5 Posts
Discussion Starter #10
Turns out that my engine had locked up even though there was oil in it already. Any suggestion on where I can get an engine that's not too **** expensive?
 
1 - 10 of 10 Posts
Top