Kia Optima Forums banner
1 - 6 of 6 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
I’ve had the three major oil leaks fixed and now I’m not leaking anymore but burning a qt every thousand or so miles. Is there a fix for this? It’s finally paid off and I’d love to drive it for a bit.

It seems like it’s lower than it once was. I occasionally bottom out on speed bumps. I don’t notice a difference in the ride or the tire wear but when I get in and out of the car it feels lower. What could be causing this? Any known issues?
 

·
Registered
2011 Kia Optima
Joined
·
3,398 Posts
A qt p/1000 miles is annoying, but nothing that will be done by Kia, so keep the oil up to full and hopefully the engine will seize in the future and you'll get a new engine installed. Just make certain the KSDS update has been done and when the CEL starts blinking, new engine time.
Odd that the suspension should drop, not usual, but if that's the case, look into the spring(s) to start.
 

·
Registered
Joined
·
49 Posts
A qt p/1000 miles is annoying, but nothing that will be done by Kia, so keep the oil up to full and hopefully the engine will seize in the future and you'll get a new engine installed. Just make certain the KSDS update has been done and when the CEL starts blinking, new engine time.
Odd that the suspension should drop, not usual, but if that's the case, look into the spring(s) to start.
They still don't have the KYB strut plus replacements.
 

·
Registered
Joined
·
49 Posts
I’ve had the three major oil leaks fixed and now I’m not leaking anymore but burning a qt every thousand or so miles. Is there a fix for this? It’s finally paid off and I’d love to drive it for a bit.

It seems like it’s lower than it once was. I occasionally bottom out on speed bumps. I don’t notice a difference in the ride or the tire wear but when I get in and out of the car it feels lower. What could be causing this? Any known issues?
 

·
Registered
Joined
·
49 Posts
Turbonut is right. Even though I usually drive it like I stole it, my '12 SX with 110K uses a quart every K but still runs quite strongly and gets 32 mpg with conservative highway driving. I have the KSDS update and if the knock CEL comes on KIA owes me a new motor!
 

·
Registered
Joined
·
37 Posts
I’ve had the three major oil leaks fixed and now I’m not leaking anymore but burning a qt every thousand or so miles. Is there a fix for this? It’s finally paid off and I’d love to drive it for a bit.

It seems like it’s lower than it once was. I occasionally bottom out on speed bumps. I don’t notice a difference in the ride or the tire wear but when I get in and out of the car it feels lower. What could be causing this? Any known issues?
Check Timing Chain, Head Gasket, etc seals. Both of those, along with a rear main seal went bad at once in my k5 when I passed 300WHP. I decided to have them all done at once, great idea. $700 later my car runs like a top, but my boost is still peaky which I'll need to figure out.
 
1 - 6 of 6 Posts
Top