Kia Optima Forums banner
1 - 7 of 7 Posts

·
Registered
2012 Kia Optima
Joined
·
8 Posts
Discussion Starter · #1 ·
So I see the oil light come on and I panic. I check it and its low. Mobil-1 with OEM Kia oil filters. 122k on car. So I did an oil change last weekend. I check it today and I need to add a quart. I also notice the car has no zoom as it usually does. Then I notice plumes of white smoke after hard accelerations. WTF? So I think to myself there has to be something wrong in the turbo end of the car and my WOT rpm is only 4k. So I let it cool down and then try the waste gate lever to see what the voltage is. NOTHING. it will not budge and no voltage. I take it apart and the small gear is stripped out. 200.00 to order a new one. Will see if this fixes everything. Im hoping it will. OBTW I got a cel of P2297. Not the waste gate code...strange
 

·
Registered
2012 Black SX Prem. & Tech.
Joined
·
2,293 Posts
If you lost a quart of oil in one week, did you see any of it dripping onto the ground under the car?

Or is the oil being burned off by the engine and making the white exhaust smoke?
 

·
Registered
2012 Black SX Prem. & Tech.
Joined
·
2,293 Posts
Maybe the head gasket is blown, allowing oil to escape somewhere, and coolant to leak into the cylinders.

Did you check your coolant level, is it also low? Or just the oil level is low, and coolant remains normal?
 

·
Registered
2012 Kia Optima
Joined
·
8 Posts
Discussion Starter · #5 ·
No oil seen anywhere. I did get the new waste gate valve, installed it and set it up for 4.0 volts. Back to normal. I just didn’t know what to expect other than the CEL for the waste gate malfunction. I don’t know if the flapper is stuck open or closed. I took the old waste unit apart to show you what happens at about 100-130K. Notice the small gear all stripped out
 

Attachments

·
Registered
2018 Kia Optima
Joined
·
1,165 Posts
I can't tell if the crud that's inside the unit is debris from the gear being worn/stripped out or from external contaminants/debris entering the unit--i.e., wondering as to what the source of the failure might be attributed to.
 

·
Registered
2012 Kia Optima
Joined
·
8 Posts
Discussion Starter · #7 ·
It is the turbo. When I hop on it I get oil smelling smoke out of the exhaust. 125k on it. Time for a new one.
 
1 - 7 of 7 Posts
Top