Kia Optima Forums banner

1 - 5 of 5 Posts

·
Registered
2012 Kia Optima
Joined
·
3 Posts
Discussion Starter #1
I have a 2012 Kia Optima with a push start. For the past year, when I go to start the car, it clicks a couple times but will not start. My battery is good. When I push the Start button the dash lights come on but makes a humm noise but won't start. If I press on the brake pedal and put the shifter in reverse and back to park and push the Start button it starts. Wondering if it's the starter or clock spring, or something else? Only happens once or twice a week which makes me think it's not the starter. Any thoughts? Thank you.
 

·
Registered
2012 Black SX Prem. & Tech.
Joined
·
1,845 Posts
something else to check: the brake switch.

If the car doesn't know the brake is pressed, it won't start. the brake switch tells the car the brake is pressed.

The brake switch can be perfectly fine, but the "pusher" part on the pedal can get messed up and not properly push the switch. You can fix it easily, see posts elsewhere on this board.

Or the switch can go bad.

Maybe if you can duplicate the problem, while someone watches for brake lights? If the problem happens only when the brake lights are not working, then it's probably the brake switch.
 

·
Premium Member
2012 Kia Optima SX-T
Joined
·
1,462 Posts
Perhaps a quick way to know if it is the rubber brake plunger on the brake pedal wearing out is to hold the start button for longer than 10 seconds. This over rides the brake switch and starts the car. If it does start, you know it is not the starter but this inexpensive fix (which I believe is being done under warranty still if needed).
 

·
Registered
Joined
·
12 Posts
Currently away from my car (had to leave it). But my Kia won’t start. It’s a 2012 Kia Optima push start and the Fob key was working just fine until tonight. Tonight I tried to start it and only my dash lit up flashing the symbols at me with a glitchy Kia logo in the middle, lots of clicking happening too. I tried inserting the Fob key, jump starting the car, and nothing worked. Anyone have any experience or advice in this? Worked perfectly fine until now. Only thing I can think of that I may have done wrong is leave the car on because my friend told me when I parked it seemed like it was still running but I assured him I turned it off it just takes a second for the lights to turn off. Now I’m not so sure.





192.168.100.1 192.168.1.1 jpg to pdf
 

·
Premium Member
2012 Kia Optima SX-T
Joined
·
1,462 Posts
Currently away from my car (had to leave it). But my Kia won’t start. It’s a 2012 Kia Optima push start and the Fob key was working just fine until tonight. Tonight I tried to start it and only my dash lit up flashing the symbols at me with a glitchy Kia logo in the middle, lots of clicking happening too. I tried inserting the Fob key, jump starting the car, and nothing worked. Anyone have any experience or advice in this? Worked perfectly fine until now. Only thing I can think of that I may have done wrong is leave the car on because my friend told me when I parked it seemed like it was still running but I assured him I turned it off it just takes a second for the lights to turn off. Now I’m not so sure.
When this happened to me, it was the battery that went bad. No real signs of it going until it did. Exactly two years (it was a two year warrantied battery). I replaced it with the WalMart Maxx and have been very happy (5yr warranty).
 
1 - 5 of 5 Posts
Top