Kia Optima Forums banner
1 - 3 of 3 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
Hi guys i’m currently at loss with my 2012 Kia Optima hybrid I recently purchased it back in November with 113,400k miles on it im not sure if this is even relevant but around december with 113,700k miles on it now the tensioner pulley belt serpentine belt the whole shebang had to be replaced not the alternator though due to an animal being grinded into the belt after that I started having a problem not even a month later saying “ hybrid system warning stop safely and do not drive “ “ charging system warning “
i currently have battery light check engine light and wrench icon light the codes that are thrown are P0A40 P0A41 P0A42 and i’m not sure what to do i just would like to know if anyone knows what part this could be so i can get it fixed i rather not go to the dealership but if i have to i will I would also like to add in that my engine does have a recall on it and they have not replaced it they basically told me they won’t replace it unless it blows up or shuts down on me and that has happened already while driving lost power the engine cut off sometimes I get a message on the display where my radio is saying that I should use the engine instead of the battery but my car is on so it seems as if the engine isn’t really working in my case anything helps please and thank you
 

·
Registered
Joined
·
22 Posts
First of all if you want more people to read without pressing the back button, use some punctuations. Lol.

At least your Optima hybrid moves. You should see my thread. I joint here just to solve that one problem, get the car moving. I paid 1000 cad for the car just as project. Engine is good starts no problem just doesn't move in any gear and it's not the shifter bushing, I was hoping it's that easy lol.

I just hope you didn't pay too much, the hybrid error you have to bring to dealer to check, this car is more complicated than my bmw 323i. This is my second attempt to mess with Hybrid cars, after the 800 bucks civic hybrid I got lasted for 8 months, sold for 500 bit lost out on the grid charger and some other fixes.
 
1 - 3 of 3 Posts
Top