Kia Optima Forums banner
1 - 10 of 10 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
‘12 Optima EX 2.4L with 129,250 miles. Feels like I’m losing power with the engine and it tightens up like I’m pressing the brakes. When I press the accelerator it’s better and goes back to the weird feeling once I release the accelerator. No knocking/vibrations. No engine lights or other lights are on. Starts fine and goes into D fine. No change in fuel mpg and no gas smell. Air filter clean. Hooked up OBDII from AutoZone and no error codes. Any leads on how to fix will be appreciated.
 

·
Registered
2011 Kia Optima
Joined
·
3,386 Posts
Difficult to diagnose with no CEL, but if it feels like the brakes are applied, sure they aren't?
These cars are terrible for sliders freezing in brackets as well as caliper piston(s) freezing in their bore.
After being driven, check to see if any wheel is hotter than the others, and when in neutral the car should be able to move easily.
 

·
Registered
2012 Black SX Prem. & Tech.
Joined
·
2,184 Posts
Hmm, could it be an issue with the transmission?

I feel like if you release the gas pedal, the transmission should allow the car to coast without feeling like you are hitting the brakes.

Does it feel like you are stuck in a lower gear, and when you release the gas pedal, the transmission applies the feeling of engine braking through that low gear?
 

·
Registered
Joined
·
27 Posts
Hmm, could it be an issue with the transmission?

I feel like if you release the gas pedal, the transmission should allow the car to coast without feeling like you are hitting the brakes.

Does it feel like you are stuck in a lower gear, and when you release the gas pedal, the transmission applies the feeling of engine braking through that low gear?
That's exactly what it feels like, my 18 EX 2.4 does the same every now and then. Read about it happening here before. Mine doesn't do it all the time so I'm not worried about it. Seems like it happens when the trans is cold in my case. BTW 13,000 miles on mine.
 

·
Registered
Joined
·
3 Posts
‘12 Optima EX 2.4L with 129,250 miles. Feels like I’m losing power with the engine and it tightens up like I’m pressing the brakes. When I press the accelerator it’s better and goes back to the weird feeling once I release the accelerator. No knocking/vibrations. No engine lights or other lights are on. Starts fine and goes into D fine. No change in fuel mpg and no gas smell. Air filter clean. Hooked up OBDII from AutoZone and no error codes. Any leads on how to fix will be appreciated.
Check to see if your car qualifies for the recall...might be able to get a new engine out of it
 

·
Registered
2020 Kia Soul X-Line 2.0 MPI
Joined
·
102 Posts
‘12 Optima EX 2.4L with 129,250 miles. Feels like I’m losing power with the engine and it tightens up like I’m pressing the brakes. When I press the accelerator it’s better and goes back to the weird feeling once I release the accelerator. No knocking/vibrations. No engine lights or other lights are on. Starts fine and goes into D fine. No change in fuel mpg and no gas smell. Air filter clean. Hooked up OBDII from AutoZone and no error codes. Any leads on how to fix will be appreciated.
What transmission maintenance have you done on it?
Please report back here, once you find out the problem and solution.
 

·
Registered
Joined
·
3 Posts
What transmission maintenance have you done on it?
Please report back here, once you find out the problem and solution.
I purchased my car last year with 98,000 kms on it. I drove it for 15,000 kms and had an issue on the highway where the control rod put a hole in my engine block. If you call Kia, speak with someone that deals with recalls and give them your vin to see if yours was on recall
 
1 - 10 of 10 Posts
Top