Kia Optima Forums banner
1 - 4 of 4 Posts

· Registered
Joined
·
50 Posts
Discussion Starter · #1 ·
Hi,

So, I have a 2011 Kia Optima that for the most part has been reliable. However, recently when I go to pump gas, the pump started shutting off early. From all the research I've done, everything states that it is almost certainly the EVAP canister going bad. Interestingly, I had the aux EVAP canister installed via recall just this past May. IDK if that is related or just coincidental timing. Maybe the main canister was going bad and the additional pressure from the aux canister just exacerbated it?

Dealer service centers are super backed up right now in my area. One place that would take appointments doesn't have any openings until 1 month from now and another place told me that I could drop off my car but it would be 3-5 days before they could look at it b/c they are so backed up. In the meantime, it takes me like 5-10 minutes to get gas, just annoying standing there slowly pumping gas.

IDK what my options really are other than to wait for my appointment or try to take it to a private shop and just tell them to replace it. I've also considered swapping it myself but I don't have any kind of car ramp/lift that I would trust my life working under and the car is kind of low to the ground in general. Maybe I could drive it on top of some bags of cement that I have?

I have a code reader and my car is not throwing a CEL or any codes yet.

Thoughts?
 

· Registered
2011 Kia Optima
Joined
·
4,414 Posts
You could do some testing, checking the filler tube with a scope to be certain no clog, check hoses,
remove vent hose and see if the fuel runs properly. As long as there isn't a restriction in the filler tube
and fuel isn't spewing out, years ago we would put a stick under the rubber seal on the pump so the
tank may breathe, not legal, but worked.
 

· Registered
2012 Black SX Prem. & Tech.
Joined
·
2,743 Posts
Have you tried a different gas station? I've had experiences where the particular gas station had the worst pumps and I couldn't get more than a little gas in at a time before the **** thing would shut off and then I'd have to sit there squeeze/click off/squeeze again/click off again/.... But it was just a bad pump. Went elsewhere and it pumped smoothly.
 

· Registered
Joined
·
161 Posts
I had the same issue with my 2011 EX and I took it to a local indie shop that did the evap canister R&R. No problem....it is not a difficult job.
 
1 - 4 of 4 Posts
Top