Need New Rear Shock 2016 Optima SX - Page 2
  1. Welcome to Kia Optima Forum – General discussion forum for Kia Optima

    Welcome to Kia Optima Forum - a website dedicated to all things Kia Optima.

    You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, at no cost, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, Join Kia Optima Forum today!
     
Page 2 of 2 FirstFirst 12
Results 11 to 14 of 14

Thread: Need New Rear Shock 2016 Optima SX

  1. #11
    Your K5 Optima Vendor K5 Optima Store's Avatar
    Join Date
    Dec 2011
    Location
    Chatsworth, CA
    Posts
    27,846
    Year
    2017
    Make
    Tesla
    Model
    Model X
    Trim
    P100D
    Quote Originally Posted by redlantrn View Post
    Thanks David. Are the Eibach Kinetic springs short enough to pair with these? Will the ride height drop little more? Car sounds like a hooptie with all the noise coming from the back.
    Welcome and yes, we have a few customers with this same setup. The struts and shocks should not cause the vehicle to ride any lower, but some others on the forum have mentioned it does, so not 100% sure on that one.





  2. Remove Advertisements
    Optima Forums
    Advertisements
     

  3. #12
    Learner's Permit
    Join Date
    Feb 2015
    Location
    Atlanta
    Posts
    254
    Year
    2016
    Make
    Kia
    Model
    Optima
    Trim
    SX
    Preciate the reply David. Was concerned about rubbing. I'm on stock wheels so hopefully should not be an issue.

  4. #13
    Learner's Permit
    Join Date
    Feb 2015
    Location
    Atlanta
    Posts
    254
    Year
    2016
    Make
    Kia
    Model
    Optima
    Trim
    SX
    *Update* Turns out I did not have a bad shock. The 3rd mechanic I took it to determined that the sway bar end links were loose. This is my own fault, as I installed it myself. I definitely learned from my mistake, but also learned that there are some mechanics about as clueless as myself. LOL. Thanks for the support Turbonut and Dave at K5!

  5. Remove Advertisements
    Optima Forums
    Advertisements
     

  6. #14
    Your K5 Optima Vendor K5 Optima Store's Avatar
    Join Date
    Dec 2011
    Location
    Chatsworth, CA
    Posts
    27,846
    Year
    2017
    Make
    Tesla
    Model
    Model X
    Trim
    P100D
    Quote Originally Posted by redlantrn View Post
    *Update* Turns out I did not have a bad shock. The 3rd mechanic I took it to determined that the sway bar end links were loose. This is my own fault, as I installed it myself. I definitely learned from my mistake, but also learned that there are some mechanics about as clueless as myself. LOL. Thanks for the support Turbonut and Dave at K5!
    Oh man this is great news, happy to hear it was a false alarm. Of course, you're very welcome, happy you were able to get it figured out and corrected.





  7. Remove Advertisements
    Optima Forums
    Advertisements
     

Page 2 of 2 FirstFirst 12

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Powered by vBadvanced CMPS v4.3.0