Tranny problems
  1. Welcome to Kia Optima Forum – General discussion forum for Kia Optima

    Welcome to Kia Optima Forum - a website dedicated to all things Kia Optima.

    You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, at no cost, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, Join Kia Optima Forum today!
     
Results 1 to 6 of 6

Thread: Tranny problems

  1. #1
    Newbie
    Join Date
    Mar 2019
    Posts
    6

    Tranny problems

    Good afternoon everyone from southeast Missouri, so 2004 Optima 2.4 auto got a code for input speed sensor had a pretty good jolt when shifting into second and third once in a great while. After replacing input and output sensors it throws it into limp mode shifts really hard now in first and second then stays in third. Still getting code and car is worse now than before can someone give me any insight on this please ?

  2. Remove Advertisements
    Optima Forums
    Advertisements
     

  3. #2
    Certified Wrench Monkey
    Join Date
    May 2015
    Location
    NJ
    Posts
    839
    Year
    2011
    Make
    Kia
    Model
    Optima
    Trim
    EX-T
    What was/is the code(s)?
    Same hot and cold?

  4. #3
    Newbie
    Join Date
    Mar 2019
    Posts
    6
    Yes same code hot or cold

  5. Remove Advertisements
    Optima Forums
    Advertisements
     

  6. #4
    Newbie
    Join Date
    Mar 2019
    Posts
    6
    P0715 po733

  7. #5
    JasonS's Avatar
    Join Date
    Jun 2014
    Location
    Indianapols, IN
    Posts
    3,289
    Year
    2012
    Make
    Kia
    Model
    Optima
    Trim
    EX 2.0
    There are 2 sensors on our transmissions, if one or more of them are bad, you'll get that behavior.
    Dynojet: 294 whp/305 torque/24lbs boost with a custom BTR tune with full bolt-ons.
    2012 Optima EX-T Spicy Red Showroom https://www.optimaforums.com/forum/4...-showroom.html w/ the following MODs: 845 Motorsports FMIC|845 Motorsports 4" Intake|845 Motorsports Charge Pipe|Nameless Midpipe|Nameless Downpipe|Synapse V3 BOV|BTR Custom Tune|Magnaflow Exhaust|Saikou Michi OCC's|Ultra Racing FSTB|kSport Coilovers|R1 Concepts rotors|and MORE...

  8. #6
    Newbie
    Join Date
    Mar 2019
    Posts
    6
    Replaced both and now it’s stuck in limp mode 3rd gear

  9. Remove Advertisements
    Optima Forums
    Advertisements
     

Similar Threads

  1. Tranny fluid change after new tranny??
    By 1st timer in forum Optima Engine and Technical Discussion
    Replies: 2
    Last Post: 11-30-2015, 05:56 PM
  2. Tranny Shift Point Change?
    By turnbowm in forum Optima General Discussion
    Replies: 6
    Last Post: 11-14-2014, 08:18 AM
  3. 2013 KOH with 2000 miles jerky tranny when cold
    By Jasper in forum Optima Hybrid
    Replies: 12
    Last Post: 07-10-2014, 07:05 AM
  4. 2013 sxl leaking tranny fluid!!!
    By Yota44 in forum Optima Engine and Technical Discussion
    Replies: 7
    Last Post: 08-06-2013, 03:13 AM
  5. Check Engine light / Tranny slipping?
    By neurotic5150 in forum Optima Engine and Technical Discussion
    Replies: 14
    Last Post: 02-05-2013, 09:29 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Powered by vBadvanced CMPS v4.3.0