RPM's Drop to 0 After aggressive braking
  1. Welcome to Kia Optima Forum – General discussion forum for Kia Optima

    Welcome to Kia Optima Forum - a website dedicated to all things Kia Optima.

    You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, at no cost, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, Join Kia Optima Forum today!
     
Results 1 to 2 of 2

Thread: RPM's Drop to 0 After aggressive braking

  1. #1
    Newbie
    Join Date
    May 2019
    Posts
    4

    RPM's Drop to 0 After aggressive braking

    So my wife's 2013 Optima SXL has had an issue over the past month where if she has to brake suddenly the RPM gauge drops to 0. It will stay at 0 until the car is stopped, shut off and then turned back on. Also when this happens the car will stutter/loss of power for a few seconds on acceleration, once you are up to speed it seems fine.

    No check engine lights on dash and i did not pull any codes with a scanner.

    Any ideas what could be causing this?

  2. Remove Advertisements
    Optima Forums
    Advertisements
     

  3. #2
    Learner's Permit Laguna's Avatar
    Join Date
    Jul 2012
    Location
    Chicago, IL
    Posts
    267
    Year
    2013
    Make
    Kia
    Model
    Optima
    Trim
    SXL
    Sounds like some sensor is failing, potentially a transmission one. Take it in.
    2013 Optima SXL - Titanium

    Chicago's Dedicated Auto Detailing

  4. Remove Advertisements
    Optima Forums
    Advertisements
     

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Powered by vBadvanced CMPS v4.3.0