transmission issue
  1. Welcome to Kia Optima Forum – General discussion forum for Kia Optima

    Welcome to Kia Optima Forum - a website dedicated to all things Kia Optima.

    You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, at no cost, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, Join Kia Optima Forum today!
     
Results 1 to 5 of 5

Thread: transmission issue

  1. #1
    Newbie
    Join Date
    Jul 2018
    Posts
    8

    transmission issue

    So...I'll start the car, put it in drive and the D appears in the display, at some point while driving the D disappears and if I have to stop and start it starts driving in either 2nd or 3, can't tell. the shifter is of no use, and if I shut off the engine and restart it's back to normal.

    Happens only a couple of times a week at most so there's no predicting. I've driven a couple of days and it's fine, then it'll do it twice in a day.

    Another wrinkle is my engine failed so it's a new short block in there. The issue started after it was done.

    It's a 14 Optima EX plus 2.4

  2. Remove Advertisements
    Optima Forums
    Advertisements
     

  3. #2
    OptimaForums Veteran
    Join Date
    Aug 2012
    Location
    Knoxville, TN
    Posts
    1,348
    Year
    2012
    Make
    Kia
    Model
    Optima SX-T
    Trim
    Premium Touring Package
    Quote Originally Posted by sidewalkman2 View Post
    So...I'll start the car, put it in drive and the D appears in the display, at some point while driving the D disappears and if I have to stop and start it starts driving in either 2nd or 3, can't tell. the shifter is of no use, and if I shut off the engine and restart it's back to normal.

    Happens only a couple of times a week at most so there's no predicting. I've driven a couple of days and it's fine, then it'll do it twice in a day.

    Another wrinkle is my engine failed so it's a new short block in there. The issue started after it was done.

    It's a 14 Optima EX plus 2.4
    Take it back to the dealer for them to diagnosis. Perhaps a wiring harness is not plugged in very well (intermittent connection)?
    __________________________________________________ _______________
    2012 Optima SX w/Premium Touring Pkg, "Spicy Red" | 80K miles
    Purchased 7/2012, built 3/13/2012 at GA plant.
    Mods: LAP3 UncleBoost ECU tune (Stage 1.5+), HKS M40XL Plugs, Saikou Michi OCCs (PCV&Intake), Injen SRI w/hydro-shield, Nameless MP and CP, Theta2 TBS, CP-E CBE, UR Crank Pulley, Ultra Racing FSTB, Eibach Pro-Kit Springs w/TruHart Struts, Advanti Kudos rims,...
    (See my Showroom for details)

  4. #3
    Riding Lawn Mower rzhao2's Avatar
    Join Date
    May 2016
    Posts
    42
    Year
    2014
    Model
    2014 optima LX 2.4
    Its definitely the inhibitor. switch, replace it and see, super easy, remove the battery and its right down there

    Sent from my Moto Z (2) using Tapatalk

  5. Remove Advertisements
    Optima Forums
    Advertisements
     

  6. #4
    Riding Lawn Mower
    Join Date
    Dec 2018
    Location
    Virginia
    Posts
    11
    Year
    2014
    Make
    Kia
    Model
    Optima
    Trim
    SXL
    Inhibitor switch. Happened to my car under warranty, but looking at it it its an easy fix if out of warranty..Its approx $30 part

  7. #5
    OptimaForums Veteran SXexcess's Avatar
    Join Date
    Feb 2012
    Location
    ABQ, NM, USA
    Posts
    1,240
    What does this inhibitor switch do, beside fail? lol
    2012 Optima SX w/ premium touring & tech packages, Corsa Blue, born in the USA Jan 24 2012, bought Feb 11 2012 w/7 miles
    Mods; 15% tint all around, clear bra, dechromed/body color grill, blue brake calipers, plastidip'd emblems, dark tint window vent visors, painted the badge T grass green (T-GDI), Fumoto oil drain valve, yellow tint fogs, mud guards, General Altimax RT43 225/50/18 tires and full size spare
    http://smg.photobucket.com/albums/v6...20Optima%20SX/

  8. Remove Advertisements
    Optima Forums
    Advertisements
     

Similar Threads

  1. Possible Transmission Shifting Issue
    By Kozentov in forum Optima Engine and Technical Discussion
    Replies: 11
    Last Post: 05-16-2015, 02:01 AM
  2. 2012 optima ex transmission issue
    By paulk in forum Optima Engine and Technical Discussion
    Replies: 5
    Last Post: 02-26-2014, 03:44 PM
  3. [SX] : Transmission Shift Shock Issue
    By DansSX in forum Optima Engine and Technical Discussion
    Replies: 2
    Last Post: 11-03-2013, 11:53 AM
  4. Help!! Transmission Issue!!
    By K5OptimaLX in forum Optima Engine and Technical Discussion
    Replies: 8
    Last Post: 10-18-2012, 04:56 PM
  5. Kia Recalling 70,000 Optimas for Transmission Issue
    By AutoGuide.com in forum Kia Optima News, Rumors and Updates
    Replies: 0
    Last Post: 03-11-2011, 06:05 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Powered by vBadvanced CMPS v4.3.0