Heater duct issues
  1. Welcome to Kia Optima Forum – General discussion forum for Kia Optima

    Welcome to Kia Optima Forum - a website dedicated to all things Kia Optima.

    You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, at no cost, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, Join Kia Optima Forum today!
     
Results 1 to 8 of 8

Thread: Heater duct issues

  1. #1
    Riding Lawn Mower
    Join Date
    Oct 2014
    Location
    Rhode Island
    Posts
    37
    Year
    2018, 2012
    Make
    Kia
    Model
    Optima
    Trim
    EX

    Heater duct issues

    My 2012 EX heating system is giving me fits.The heater modes all seem to be functioning properly but the air is hardly blowing thru the vents. The blower motor is working correctly as I can hear the speeds increasing and the air is moving, although slightly thru the proper vents. The same thing is happening with the AC. Is there one particular blend door that is not functioning correctly that would affect all the other vents. I would think it would have to be near the blower motor to affect the heater vents and the defroster.

  2. Remove Advertisements
    Optima Forums
    Advertisements
     

  3. #2
    Banned
    Join Date
    Dec 2011
    Location
    Albany, NY
    Posts
    3,292
    Did you check the filter?

  4. #3
    Riding Lawn Mower
    Join Date
    Oct 2014
    Location
    Rhode Island
    Posts
    37
    Year
    2018, 2012
    Make
    Kia
    Model
    Optima
    Trim
    EX
    Quote Originally Posted by XxHaimBondxX View Post
    Did you check the filter?
    First thing I did. Brand new. I even tried it without the filter.

  5. Remove Advertisements
    Optima Forums
    Advertisements
     

  6. #4
    Banned
    Join Date
    Dec 2011
    Location
    Albany, NY
    Posts
    3,292
    Right, but did the old filter have debris or fur, indicating you may have a rodent problem?

    I would invest in one of those usb rope cameras and poke around inside the vents to see what's happening.
    Last edited by XxHaimBondxX; 01-27-2019 at 09:56 AM.

  7. #5
    Riding Lawn Mower
    Join Date
    Oct 2014
    Location
    Rhode Island
    Posts
    37
    Year
    2018, 2012
    Make
    Kia
    Model
    Optima
    Trim
    EX
    No indication at all of anything in there. No indication of mice. I`m thinking that where ever the blockage is has to be before the defroster duct because that is affected as well as all the other vents.

  8. #6
    Bazinga!
    Join Date
    Sep 2011
    Posts
    1,961
    Model
    Optima
    My 2011 has been the same way since new. Only way to even really feel the air blowing out is to turn it to full speed. I just live with it. It's not a bad blower motor and it's not a clogged filter.

  9. #7
    Riding Lawn Mower
    Join Date
    Jan 2018
    Posts
    38
    Model
    2015 Optima EX
    I thought the same thing with my 2015 EX when on Auto mode. When I have it on manual it appears to work as it should. I am not certain how the auto climate control function works, but it does heat or cool off my car, it just doesnt feel like anything coming out of the main dash vents. Honestly, I am not sure where the air is coming out....

  10. #8
    Driver's License
    Join Date
    Feb 2018
    Location
    NorCal
    Posts
    356
    Year
    2018
    Make
    Kia
    Model
    Optima
    Trim
    SXL
    I can't speak for pre-2018 MY Optimas but on my 2018 SXL it has the Auto Defogging System feature which uses a sensor to detect the amount of humidity within the passenger compartment to determine which vent(s) to open when the HVAC is turned on and set to Auto mode; I find that when the inside and/or ambient temps are below ~75 deg F (to be honest I can't say for sure as to what the actual temperature is inside my car since it's not as if I carry a thermometer wherever I go) and I turn on the HVAC to Auto mode and the temp knob set to no higher than around 76 deg F, the display shows AUTO along with the defrost symbol, and as a result of that I do notice that more (cool) air is coming out from the defrost vents than from the dash vents--eventually the air flow does switch to the front vents (display shows the front vent symbol/arrow), most likely because at that point the ADS is no longer detecting a lot of humidity inside the vehicle.

    OTOH during hot (and dry) days (e.g., when the car's been sitting out in the hot sun all day long at work) when I turn on the HVAC to Auto with temp knob at or below 76 the display shows the front vent symbol/arrow and I feel pretty much the full blast of air coming from the front vents.
    Last edited by tonester; 05-03-2019 at 11:09 AM.

  11. Remove Advertisements
    Optima Forums
    Advertisements
     

Similar Threads

  1. Shower Duct??
    By kennyz in forum Optima General Discussion
    Replies: 1
    Last Post: 05-25-2018, 12:18 AM
  2. Replies: 6
    Last Post: 09-16-2016, 11:15 AM
  3. Has anyone opened the Air duct?
    By nhromada in forum Optima Engine and Technical Discussion
    Replies: 6
    Last Post: 01-19-2016, 11:25 PM
  4. 2007 Magentis Climate/Heater Control Issues
    By latinoloco in forum Optima General Discussion
    Replies: 1
    Last Post: 12-19-2012, 11:23 PM
  5. Surprise Surprise [Issues and more Issues :( ]
    By Black_V!per in forum Optima Appearance and Body Modifications
    Replies: 16
    Last Post: 01-17-2012, 02:19 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Powered by vBadvanced CMPS v4.3.0