Nav/GPS a little off
NEWS
 

  1. Welcome to Kia Optima Forum – General discussion forum for Kia Optima

    Welcome to Kia Optima Forum - a website dedicated to all things Kia Optima.

    You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, at no cost, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, Join Kia Optima Forum today!
     
+ Reply to Thread
Page 1 of 3 123 LastLast
Results 1 to 10 of 21

Thread: Nav/GPS a little off

  1. #1
    Learner's Permit
    Join Date
    Apr 2015
    Location
    Toronto, Canada
    Posts
    100
    Year
    2014
    Make
    Kia
    Model
    Optima
    Trim
    SX Turbo

    Nav/GPS a little off

    Hey guys. I've researched and couldn't find much. Sorry if I missed the thread.

    Anyway, driving home today it noticed my navigation was off. GPS was high or something. It was putting me close, but it was going all wonky on me.

    Everything else was working fine.

    I have a '14 SX-T and upgraded the map to the 9.5V a while back.

    Any idea why my GPS went wacky?
    2014 Optima SX Turbo, graphite, stock

  2. Remove Advertisements
    Optima Forums
    Advertisements
     

  3. #2
    K5 Optima Store Vendor Paul@K5OptimaStore's Avatar
    Join Date
    Jun 2015
    Location
    Raleigh, NC
    Posts
    632
    Year
    2013/2007
    Make
    Hyundai/Nissan
    Model
    Santa Fe/350z
    That's strange, I wonder if you could take it to the dealership. Not sure if you can calibrate them or not or if the area you were in just had bad satellite signal. Has it done this before?
    ​​





  4. #3
    Learner's Permit
    Join Date
    Apr 2015
    Location
    Toronto, Canada
    Posts
    100
    Year
    2014
    Make
    Kia
    Model
    Optima
    Trim
    SX Turbo
    Quote Originally Posted by Paul@K5OptimaStore View Post
    That's strange, I wonder if you could take it to the dealership. Not sure if you can calibrate them or not or if the area you were in just had bad satellite signal. Has it done this before?
    I'm hoping it was just a blip in the satellite signal in my area. I called my pops who has a Cadenza and asked him to check his GPS info. It was all good. He lives about 200 Kim's away though. I'll check it out tomorrow and see what's up. Otherwise a trip to the dealsership it is...

    ---------- Post added 03-27-2017 at 06:57 PM ---------- Previous post was 03-26-2017 at 08:58 PM ----------

    Well, after driving for about 20 minutes today the receiver picked up the satellite. All good now. Very bizarre.
    2014 Optima SX Turbo, graphite, stock

  5. Remove Advertisements
    Optima Forums
    Advertisements
     

  6. #4
    Learner's Permit
    Join Date
    Apr 2015
    Location
    Toronto, Canada
    Posts
    100
    Year
    2014
    Make
    Kia
    Model
    Optima
    Trim
    SX Turbo
    Quote Originally Posted by Floger View Post
    I'm hoping it was just a blip in the satellite signal in my area. I called my pops who has a Cadenza and asked him to check his GPS info. It was all good. He lives about 200 Kim's away though. I'll check it out tomorrow and see what's up. Otherwise a trip to the dealsership it is...

    ---------- Post added 03-27-2017 at 06:57 PM ---------- Previous post was 03-26-2017 at 08:58 PM ----------

    Well, after driving for about 20 minutes today the receiver picked up the satellite. All good now. Very bizarre.
    Update

    GPS system started acting up again. Brought it to the dealership. 45 minutes later they ordered a new Nav system barely under warranty. I'll update once installed next week.

    Does anyone know who manufactures the 2014 NAV system. The dealership can't tell me. I called Kia Canada. They said they don't even know. Does anyone know?
    Last edited by Floger; 03-31-2017 at 01:34 PM.
    2014 Optima SX Turbo, graphite, stock

  7. #5
    Learner's Permit
    Join Date
    Apr 2015
    Location
    Toronto, Canada
    Posts
    100
    Year
    2014
    Make
    Kia
    Model
    Optima
    Trim
    SX Turbo
    Quote Originally Posted by Floger View Post
    Update

    GPS system started acting up again. Brought it to the dealership. 45 minutes later they ordered a new Nav system barely under warranty. I'll update once installed next week.

    Does anyone know who manufactures the 2014 NAV system. The dealership can't tell me. I called Kia Canada. They said they don't even know. Does anyone know?
    Update - Head unit replaced last week. On the 15 min drive home it wouldn't connect to the satellites. Called the dealership and they recommended I leave the car for the day so they can open a ticket with the Kia Canada Techs. Two days later after a 30 minute drive it connected. Thought it was fine. Next day it still worked. This morning, it wouldn't connect to the satellites after a 40 minute drive. On the way home it connected after about minutes on the road. This is becoming very annoying. Called the dealership and they said if it works tomorrow not to bother coming in as they wouldn't be able to diagnose it. So basically it's a crap shoot on when they can diagnose the issue at this point.

    Can someone tell me if this is right? Satellites connect to the shark fin antenna. Antenna sends signal to the receiver (head unit) which gets transmitted to the navigation screen?
    2014 Optima SX Turbo, graphite, stock

  8. #6
    OptimaForums Veteran KingFatty's Avatar
    Join Date
    May 2013
    Posts
    1,225
    Year
    2012
    Model
    Black SX Prem. & Tech.
    Maybe there is a way to check the signal strength coming off the GPS antenna? Maybe the antenna is messed up or the antenna cable is broken so any head unit you install will not get any signal, as though the GPS antenna were disconnected, even though the antenna seems like it's connected.

    If you can't find a tool to check the antenna, maybe there is a way to connect a known good antenna (can the head unit accept one of those USB puck antennas for adding GPS to a laptop computer?) to your head unit and see that it works perfectly, then you know there is something wrong with your antenna, and that the head unit is fine.

  9. #7
    Learner's Permit
    Join Date
    Apr 2015
    Location
    Toronto, Canada
    Posts
    100
    Year
    2014
    Make
    Kia
    Model
    Optima
    Trim
    SX Turbo
    Quote Originally Posted by KingFatty View Post
    Maybe there is a way to check the signal strength coming off the GPS antenna? Maybe the antenna is messed up or the antenna cable is broken so any head unit you install will not get any signal, as though the GPS antenna were disconnected, even though the antenna seems like it's connected.

    If you can't find a tool to check the antenna, maybe there is a way to connect a known good antenna (can the head unit accept one of those USB puck antennas for adding GPS to a laptop computer?) to your head unit and see that it works perfectly, then you know there is something wrong with your antenna, and that the head unit is fine.
    Yea, I hear ya KingFatty. Makes sense. My gut tells me that it's an antenna issue. I've researched extensively and there's not much out there for this situation. My car is being left at the dealership today. I'll update later.

    ---------- Post added at 10:05 AM ---------- Previous post was at 08:06 AM ----------

    Quote Originally Posted by Floger View Post
    Update - Head unit replaced last week. On the 15 min drive home it wouldn't connect to the satellites. Called the dealership and they recommended I leave the car for the day so they can open a ticket with the Kia Canada Techs. Two days later after a 30 minute drive it connected. Thought it was fine. Next day it still worked. This morning, it wouldn't connect to the satellites after a 40 minute drive. On the way home it connected after about minutes on the road. This is becoming very annoying. Called the dealership and they said if it works tomorrow not to bother coming in as they wouldn't be able to diagnose it. So basically it's a crap shoot on when they can diagnose the issue at this point.

    Can someone tell me if this is right? Satellites connect to the shark fin antenna. Antenna sends signal to the receiver (head unit) which gets transmitted to the navigation screen?
    Of course on the drive to the dealership this morning the GPS wasn't working. When I arrived, the service manager got in the car while I waited inside. He spent maybe 5 minutes in it. He came back in and said it was working. We go in the car together and shows me the arrow moving while he drove in slow donuts in the lot. I pressed the GPS info button and of course the satellites starting picking up. Not only four satellites, but 7 green picked up. It's a head shaker. Can't diagnose anything unless it's not working. Gotta go back when it's not. Who's got time for this!
    2014 Optima SX Turbo, graphite, stock

  10. #8
    Learner's Permit
    Join Date
    Apr 2015
    Location
    Toronto, Canada
    Posts
    100
    Year
    2014
    Make
    Kia
    Model
    Optima
    Trim
    SX Turbo
    On a drive yesterday, of course the nav didn't work. Since I was driving towards the dealership I stopped in. Luckily the service manager was in and was available to go for a 5 minute drive to witness my issue. Map was working, but the arrow was in odd places and not able to recalculate correctly. It was a head shaker for him as well. He popped the SIM card map out, restarting the system which I have done before. Guess what? The satellites picked up. Great.

    He said he'll still have his tech guy make sure the software is up to date. I came back 45 minutes later when the tech was free. Of course during that time my gps worked. They hooked it up and said everything was current.

    There is no remedy for this issue according to the manager. He did witness it. They did replace the head unit previously, but there was nothing else they could do.

    Any suggestions on what to do now?
    Last edited by Floger; 04-14-2017 at 09:03 AM.
    2014 Optima SX Turbo, graphite, stock

  11. #9
    Riding Lawn Mower
    Join Date
    Jun 2015
    Location
    Orlando, FL
    Posts
    9
    Year
    2015
    Make
    Kia
    Model
    Optima
    Trim
    SX Turbo
    Have they checked/replaced the antenna cable or the antenna itself? As mentioned earlier the headunit could be fine, but without a working antenna/cable...

  12. #10
    Learner's Permit
    Join Date
    Apr 2015
    Location
    Toronto, Canada
    Posts
    100
    Year
    2014
    Make
    Kia
    Model
    Optima
    Trim
    SX Turbo
    Quote Originally Posted by GenuineMP5 View Post
    Have they checked/replaced the antenna cable or the antenna itself? As mentioned earlier the headunit could be fine, but without a working antenna/cable...
    GenunieMP5, that would be too logical. At this point they won't do anything else unless the tablet they plug in shows discrepancies in anything. I'm 0-2 with that even though the service manager witnessed it being all wonky.

    Also the service manager stated that if it was the antenna, it would be a clear defective item. By that, he meant that it would would never work 100% of the time. How would you respond to that?
    2014 Optima SX Turbo, graphite, stock

  13. Remove Advertisements
    Optima Forums
    Advertisements
     

+ Reply to Thread
Page 1 of 3 123 LastLast

Similar Threads

  1. Aftermarket GPS for Kia A2DP BT radio (non-Nav)
    By philbytx in forum Entertainment: Audio, Navigation, and Electronics
    Replies: 2
    Last Post: 12-03-2012, 01:28 PM
  2. Non-Nav GPS options?
    By Southpaw32 in forum Entertainment: Audio, Navigation, and Electronics
    Replies: 16
    Last Post: 04-04-2012, 12:09 AM
  3. GPS in Nav system used for location
    By Arizona Willie in forum Optima General Discussion
    Replies: 14
    Last Post: 02-19-2012, 03:30 PM
  4. F/S: Kenwood GPS Nav system
    By superman112 in forum Classified Forum
    Replies: 1
    Last Post: 08-23-2011, 08:51 PM
  5. GPS Nav and blue tooth?
    By Barbosa in forum Optima General Discussion
    Replies: 4
    Last Post: 06-23-2010, 03:14 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
Powered by vBadvanced CMPS v4.1.2